Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88277 - include cache modules
Summary: include cache modules
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 15:21 UTC by Scott Sibert
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version: 2.0.45-5
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-19 09:19:10 UTC


Attachments (Terms of Use)

Description Scott Sibert 2003-04-08 15:21:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
httpd.conf has parameters for Apache 1.3 version of mod_proxy (ie. CacheRoot)
which is very different from Apache 2.0 version of mod_proxy; caching should use
mod_cache for 2.0

Version-Release number of selected component (if applicable):
httpd-2.0.40-21

How reproducible:
Always

Steps to Reproduce:
1. edit /etc/httpd/conf/httpd.conf
2.
3.
    

Actual Results:  starting the web server after uncommenting the parameters returns:

Starting httpd: Syntax error on line 1020 of /etc/httpd/conf/httpd.conf:
Invalid command 'CacheRoot', perhaps mis-spelled or defined by a module not
included in the server configuration


Expected Results:  should've started

Additional info:

it looks like nobody tested this

Comment 1 Joe Orton 2003-04-09 15:24:20 UTC
The caching modules aren't very stable in Apache 2.0.40 so weren't included; I'd
recommend using Squid instead.  They'll be included once we upgrade to a more
recent 2.0 release.


Comment 2 Joe Orton 2003-05-19 09:19:10 UTC
The cache modules are now included in httpd-2.0.45-5, in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.