Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88263 - incorrect info displayed in auth window for smb
Summary: incorrect info displayed in auth window for smb
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 11:24 UTC by Thomas M Steenholdt
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-06 09:59:41 UTC


Attachments (Terms of Use)

Description Thomas M Steenholdt 2003-04-08 11:24:36 UTC
Description of problem:

When connecting to a samba server from nautilus using the uri smb://server/share
an auth window pops up, asking for credentials.

This authentication window has a warning message that says "Your password will
be transmitted unencrypted" however this can't be the case as the connection
succeeds and that would not have happened with clear-text password.
Also, having skimmed the code, the cli_session_setup() function that appears to
be handling the setup of this deviceless connection has a password field as well
as an NTpassword fiels, which suggests to me that one is used for clear-text and
one for encrypted passwords. 
I'm not a samba developer and i only skimmed the code as i got worried because
of the dialog...

So tell me, isn't the password actually encrypted during this or what?



Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. enter smb://server_name/share_name and hit enter in nautilus
2. watch the screen carefully :)

    
Actual results:
displays an auth dialog with a warning on it

Expected results:
displays an auth dialog without a warning on it


Additional info:

Comment 1 Alexander Larsson 2003-08-06 09:59:41 UTC
The message is completely unrelated to what is going on in reality.
See upstream bugzilla for this:
http://bugzilla.gnome.org/show_bug.cgi?id=119175


Note You need to log in before you can comment on or make changes to this bug.