Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88257 - while using multiple terminal selection on grub, the selected terminal is not propagated to the kernel
Summary: while using multiple terminal selection on grub, the selected terminal is not...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: grub
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 08:34 UTC by Arenas Belon, Carlo Marcelo
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-09 00:39:07 UTC


Attachments (Terms of Use)
patch that applies to 0.93-5 to add the option detailed (deleted)
2003-04-08 08:37 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff
file with the configuration files shown for the test case (deleted)
2003-04-08 08:51 UTC, Arenas Belon, Carlo Marcelo
no flags Details

Description Arenas Belon, Carlo Marcelo 2003-04-08 08:34:24 UTC
Description of problem:

if a command like :

  terminal --timeout=10 serial console

is used on the grub configuration, a polling process is started that allow the 
user to select the terminal where it is connected and that is going to be used 
as input/output for the grub console.

after any key is pressed or the timeout is reached, the console selected (the 
first one if no key is pressed) is being used to display the menu and gather 
input for the user.  the problem is that if a linux kernel is selected, there 
is no way to notify the kernel which console was selected by the boot loader 
and therefore the boot console used by the kernel is selected again using the 
linux kernel heuristics (if a console parameter is used, that console is 
selected, if several console parameters where used, the output goest to all the 
consoles defined and the input is received from the last one selected, if none 
console parameter is used, the kernel tests for a vga card and if it founds one 
it uses that as a console or the first serial port)

Version-Release number of selected component (if applicable):
All

Actual results:

the console selected by the kernel depends on the "console" parameters appended 
or in its own heuristic without any clue from the boot loader

Expected results:

if the serial console is selected, the kernel should get notified that it is 
running on a serial console and its configuration from the bootloader, and the 
parameters used should match the terminal selected

Additional info:

in order to allow different parameters to be appended to the kernel 
conditionally a conditional parameter has been added to configutil to allow it 
to load a different configuration for each terminal defined.

the first configuration is loaded (grub.conf) that allows the user to select a 
terminal, then a different configuration is loaded for each posible terminal 
being selected (grub-serial.conf or grub-console.conf).

using this process, the user is allowed to use any option that matches its 
selected terminal on a terminal by terminal basis (console parameters, splash 
images, special titles)

Comment 1 Arenas Belon, Carlo Marcelo 2003-04-08 08:37:20 UTC
Created attachment 90993 [details]
patch that applies to 0.93-5 to add the option detailed

could be used on older versions and the latest CVS too

Comment 2 Arenas Belon, Carlo Marcelo 2003-04-08 08:51:41 UTC
Created attachment 90994 [details]
file with the configuration files shown for the test case

Comment 3 Jeremy Katz 2003-04-09 00:39:07 UTC
This isn't something that's going to be added as a local patch and doesn't
really make a whole lot of sense to me.  If you do an install using a serial
console, then anaconda will set up both grub and the post-install kernel for use
with serial consoles.

If you feel strongly about it, feel free to file in the upstream bug reporting
system at http://bugcomm.enbug.org/?project=grub&mode=project


Note You need to log in before you can comment on or make changes to this bug.