Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88244 - no GUI after upgrade
Summary: no GUI after upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 9
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-08 04:57 UTC by Volker Meyer
Modified: 2007-03-27 04:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 20:32:47 UTC


Attachments (Terms of Use)

Description Volker Meyer 2003-04-08 04:57:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0 (BDP)

Description of problem:
while up2date-gnome worked perfectly before the upgrade to RH9, now it
produces the following error:
---
(up2date:1561): Gdk-WARNING **: DESKTOP_STARTUP_ID contains invalid UTF-8
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 993, in ?
    main()
  File "/usr/sbin/up2date", line 772, in main
    from up2date_client import gui
  File "gui.py", line 24, in ?
ImportError: No module named ui


Version-Release number of selected component (if applicable):
up2date-gnome-3.1.23-1

How reproducible:
Always

Steps to Reproduce:
1. run up2date on an X-Server
2.
3.
    

Actual Results:  See error-msg.

Expected Results:  What would one expect??? =:))))

Additional info:

Comment 1 Adrian Likins 2003-04-09 19:30:19 UTC
what was the upgrade to 9 from?

the module in question should be in the
package gnome-python2

can you verify that package is installed?

   rpm -q gnome-python2 

It is required by the up2date-gnome package, so
it should be there, but the error you quote
seems to indicate it is not. 

What mechanism was used to upgrade to 9?

Comment 2 Volker Meyer 2003-04-10 05:43:06 UTC
Hi,
upgrade was from RH8.0 to RH9.
-
[vmeyer@tassilo vmeyer]$rpm -V gnome-python2
[vmeyer@tassilo vmeyer]$rpm -q gnome-python2
gnome-python2-1.99.14-5
[vmeyer@tassilo vmeyer]$
-
Package appears to be correctly installed
-
The mechanism to upgarde was rpm in conjunction with up2date.
The "old" up2date was launched from the commandline with
"up2date -d up2date"
Several dependencies were checked and a few additional packages were downloaded.
I don't recall all of them, but all the packages in question were put in a
seperate folder from which the command 
rpm -Uvh *.rpm 
was issued.
Installation worked without errors.

Comment 3 Volker Meyer 2003-04-10 06:22:46 UTC
Meanwhile not even the commandline-version works.
I get the error:
-
[root@tassilo root]$up2date -l
There was an SSL error: [('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]
A common cause of this error is the system time being incorrect. Verify that the
time on this system is correct.
[root@tassilo root]$
-
I can set the time to whatever time I want. I can change the value of TZ to
whatever zone I please: I always get the error
-
Volker.

Comment 4 Mark J. Cox 2003-06-02 11:42:14 UTC
Removing security status - upgrading from 8.0 to 9 by just updating the rpms may
well have unexpected side effects.

Comment 5 Need Real Name 2004-01-20 15:36:01 UTC
I had the same problem. 

A fix is to remove the "orphaned" directory
/usr/lib/python2.2/site-packages/gnome so that the right directory 
/usr/lib/python2.2/site-packages/gtk-2.0/gnome gets used.

Also may need to update libbonobo. The one that came with RH8 was
missing a few files.


Note You need to log in before you can comment on or make changes to this bug.