Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88214 - procmail has default 50mb limit for mailbox files
Summary: procmail has default 50mb limit for mailbox files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postfix
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: John Dennis
QA Contact: David Lawrence
URL:
Whiteboard:
: 97883 110687 113396 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 18:33 UTC by Jay Thorne
Modified: 2007-04-18 16:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-12 18:35:59 UTC


Attachments (Terms of Use)

Description Jay Thorne 2003-04-07 18:33:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
Lots of my users tend to use "Leave Mail On Server" options in various MUA's
using POP3 or IMAP. Procmail has a default 50mb limit on mailbox size, so it
starts hitting the limit and bouncing pretty quickly when they start mailing
around image documents and such. 

Version-Release number of selected component (if applicable):
procmail-3.22-7

How reproducible:
Always

Steps to Reproduce:
1. Set up procmail at MTA using sendmail or postfix
2. mail enough mail to make a 49.9 meg mailbox file.
3. mail again to that account
    

Actual Results:  Mail bounces

Expected Results:  Mail should not bounce

Additional info:

50mb is too small with the usual kind of corporate user. A config param or
command line param is needed.

Comment 1 Jens Petersen 2004-01-06 01:19:12 UTC
*** Bug 97883 has been marked as a duplicate of this bug. ***

Comment 2 Jens Petersen 2004-01-06 01:20:06 UTC
*** Bug 110687 has been marked as a duplicate of this bug. ***

Comment 3 Jens Petersen 2004-01-06 03:43:30 UTC
I have a 61MB mbox file on nfs which seems to be getting mail
from procmail ok.  Does it depend on the type of fs?

Comment 5 Ian Macdonald 2004-01-06 04:29:08 UTC
No wonder I couldn't find this in the procmail source or docs. Using
mailbox_size_limit fixed the problem for me.

Comment 6 Jens Petersen 2004-01-06 07:48:04 UTC
Ok, good.

Comments to Jay Thorne:

Are you sure this also happens with sendmail?
I can only find reports on this for postfix.
AFAICT procmail itself doesn't impose any mailbox
size limits.

Comment 8 John Dennis 2004-01-12 18:35:59 UTC
Postfix imposes a limit on mailbox size to prevent runaway writing
during local delivery. The parameter which controls this is
"mailbox_size_limit", it defaults to 50 Mb. All you should need to do
is set this parameter higher in your main.cf file. You can fild an
example and documentation here:

/usr/share/doc/postfix-*/samples/sample-local.cf

Comment 9 John Dennis 2004-01-20 14:47:01 UTC
*** Bug 113396 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.