Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88208 - sre.py:137:search:TypeError:expected string or buffer
Summary: sre.py:137:search:TypeError:expected string or buffer
Keywords:
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 17:39 UTC by Gerald Teschl
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:31 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-04-07 17:39:48 UTC
If I start neat, it will just crash with a traceback:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:search:TypeError:
expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 154, in __init__
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 225, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 232, in loadDevices
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 210, in getDeviceList
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 117, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/plugins/NCDevWireless.py",
line 34, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCWireless.py",
line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137,
in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer


On the console I get:
Copying ifcfg-eth0 to devices and putting it into the default profile.
Warning : Device eth1 has been compiled with version 14
of Wireless Extension, while we are using version 15.
Some things may be broken...

Copying ifcfg-eth1 to devices and putting it into the default profile.
Warning : Device eth1 has been compiled with version 14
of Wireless Extension, while we are using version 15.
Some things may be broken...

Warning : Device eth1 has been compiled with version 14
of Wireless Extension, while we are using version 15.
Some things may be broken...

Comment 1 Gerald Teschl 2003-04-07 17:56:27 UTC
Just debuged this: You don't test if KEY is present. So if a wireless file
has no KEY=.... entry neat will crash.

Comment 2 Harald Hoyer 2003-04-07 22:34:39 UTC
get the update from
http://people.redhat.com/harald/redhat-config-network

Comment 3 Harald Hoyer 2003-04-08 11:57:39 UTC

*** This bug has been marked as a duplicate of 88147 ***

Comment 4 Gerald Teschl 2003-04-08 15:08:44 UTC
Works now. Thanks!

Comment 5 Red Hat Bugzilla 2006-02-21 18:52:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.