Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88204 - tftp-server infinite log if directory is missing (which is default)
Summary: tftp-server infinite log if directory is missing (which is default)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tftp
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 17:26 UTC by Daniel
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-11 14:46:54 UTC


Attachments (Terms of Use)

Description Daniel 2003-04-07 17:26:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5

Description of problem:
The rpm for tftp-server on RedHat 8.0 uses a default server-root of /tftpboot.
It doesn't create a /tftpboot, though. If you do a "tftp localhost" and "get
foo," eh tftp server goes crazy, and logs "file not found" to syslog infinitely,
in a loop.


Version-Release number of selected component (if applicable):
redhat 8.0 default

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh tftp-server
2. chkconfig tftpd on
3. service xinitd restart
4. tftp localhost
5. get foo
    

Actual Results:  Client behaves appropriately. Server goes into a loop,
reporting "file not found" to syslog, until disk is full.

It looks like xinitd is actually spawning many tftpd's, and sending the same
request to each of them.

Expected Results:  Server should log once.

Additional info:


If I do "mkdir /tftpboot," everything works fine.

Comment 1 Elliot Lee 2003-04-11 14:46:54 UTC
Fixed in 0.33-1 (rawhide)


Note You need to log in before you can comment on or make changes to this bug.