Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88199 - Wrong FTP URL handling
Summary: Wrong FTP URL handling
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 16:51 UTC by David Balažic
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-05 16:54:10 UTC


Attachments (Terms of Use)
The HTML used for testing (deleted)
2003-04-07 17:12 UTC, David Balažic
no flags Details

Description David Balažic 2003-04-07 16:51:29 UTC
Description of problem:

The code handling FTP URLs ( ftp://... ) in mozilla fails on some valid URLs, like :

First FTP server info :
hostname : rcum.uni-mb.si
user     : uel003r2a
pass     : xxxx ( it was really something else and I changed it since again )
user home dir : $el_a:[uel003r2a]
system : OpenVMS , file/directory names are case insensitive
used test files :
  $el_a:[UEL003R2A]DAVID.SIG;5
  $el_a:[UEL003R2A.WWW]NDA.PNG;1
  $el_a:[UEL003R2A.WWW]TEST.TXT;2
  $el_a:[UEL003R2A.WWW]TEST.TXT;3
  $el_a:[UEL008R2A.WWW]JAZ.JPG;1
  UMB1::SYS$SPECIFIC:[FAL$SERVER]NETSERVER.LOG;1
used test directories :
  $el_a:[UEL003R2A]
  $el_a:[UEL003R2A.WWW]
  $el_a:[UEL003R2A.STUFF]


Failed URLs :
ftp://uel003r2a:xxxx@rcum.uni-mb.si/WWW//david.sig
ftp://uel003r2a:xxxx@rcum.uni-mb.si/[.WWW]/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[uel003r2a]/WWW/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/WWW/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/../uel003r2a/WWW/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/[-]/uel003r2a/stuff/[-]/www/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/[-]/uel003r2a/stuff/[-]/[.www]/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/STUFF/../WWW/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/STUFF/[-.WWW]/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/STUFF/[-.WWW]NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/STUFF/[uel003r2a.WWW]/NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/$el_a%3a[000000]/uel003r2a/STUFF/[uel003r2a.WWW]NDA.PNG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/../UEL008R2A/www/JAZ.JPG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/[UEL008R2A.WWW]/JAZ.JPG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/[UEL008R2A]/WWW/JAZ.JPG
ftp://uel003r2a:xxxx@rcum.uni-mb.si/UMB1%3a%3a/SYS$SPECIFIC%3a/[FAL$SERVER]/NETSERVER.LOG

Second FTP server info :
hostname : naomi ( on mydomain )
user     : stein
pass     : test12 ( changed since )
user home dir : /home/stein
system : HP-UX (unix)
used test files :

/home/stein/test.txt
/home/stein/te1/test1.txt
/home/stein/te1/te11/test11.txt
/home/stein/te2/
/home/x/y.txt
/tmp/tmp1.txt
/tmp/te1/
/tmp/te2/tmp2.txt

Failed URLs:
ftp://stein:test12@naomi/te1//test.txt
ftp://stein:test12@naomi/../x/y.txt
ftp://stein:test12@naomi/../../tmp/tmp1.txt
ftp://stein:test12@naomi/te1/%2ftmp/tmp1.txt


These files were transfered in binary ( "I" ) mode instead of ascii ( "A" ) :
ftp://uel003r2a:xxxx@rcum.uni-mb.si/UMB1%3a%3aSYS$SPECIFIC%3a[FAL$SERVER]NETSERVER.LOG;type=a
ftp://uel003r2a:xxxx@rcum.uni-mb.si/www/test.txt%3b2;type=a

I guess mozilla lacks support for the ";type=" part of the URL.

Version-Release number of selected component (if applicable):

mozilla-1.2.1-26
How reproducible:


I tested all this by creating a local HTML file, containing the above ( and
other ) links. The file also conatin a success/failure table for mozilla and
other programs, together with a detailed description ( as a HTML comment ), how
a certain URL failed.
Currently I only have the results for mozilla.

Comment 1 David Balažic 2003-04-07 17:12:48 UTC
Created attachment 90966 [details]
The HTML used for testing

I loaded this up in mozilla ( file:///home/stein/ftp.url.test.html ) and
clicked on each link, observing the results ( it should load up the requested
document without any errors ). I put OK for correct behavior and FAIL for
failing. There is a HTML comment after each FAIL, describing what happened,
usually this is the content of the error dialog that mozilla presented.

Comment 2 Christopher Blizzard 2003-05-05 16:54:10 UTC
Looks like this was also filed upstream as:

http://bugzilla.mozilla.org/show_bug.cgi?id=203890


Note You need to log in before you can comment on or make changes to this bug.