Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88159 - Umount problem after prelink -avm
Summary: Umount problem after prelink -avm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: prelink
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 07:43 UTC by Sepp Rudel
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-06 07:31:34 UTC


Attachments (Terms of Use)

Description Sepp Rudel 2003-04-07 07:43:16 UTC
Description of problem:

After installing RH9 (and betas that preceeded it) and running

prelink -avm

causes following error during next boot:

umount: /: device is busy

If the same command is run later, no error appear.

Version-Release number of selected component (if applicable):

prelink coming with RH9.

How reproducible:


Steps to Reproduce:
1. Install RH9
2. Run prelink -avm
3. Reboot and look at the messages
    
Actual results:

umount gives errors.

Expected results:

umount goes ok.

Additional info:

I know the instructions to reproduce are PITA and it may well be that prelinking
some certain files is the cause but since I don't have a slightest clue what it
might be, I won't iterate this. However, as noted above, I've noticed this same
behaviour with RH9, and every 8.0.9x betas. Probably with RH8, too, IIRC.

Comment 1 Jakub Jelinek 2003-04-07 07:46:20 UTC
Does
telinit u
after
prelink -avm
help? Without that, /sbin/init is still using the old copy of libc and thus
the root is really busy.

Comment 2 Sepp Rudel 2003-04-07 16:40:43 UTC
But of course! telinit u solved the problem. Perhaps this could be mentioned on
the man page, there was some noise about this amongst the Debian tribe IIRC.

FWIW, I can now reproduce this naturally with:

prelink -au
reboot
prelink -avm
reboot
[etc]

Comment 3 Jakub Jelinek 2003-10-06 07:31:34 UTC
prelink 0.3.0-1 and later (ATM 0.3.0-6) should deal with it in the cron script
which does the prelinking automatically.


Note You need to log in before you can comment on or make changes to this bug.