Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88152 - Dictionary data ([acklmqsuvw].lib) truncated
Summary: Dictionary data ([acklmqsuvw].lib) truncated
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pydict
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-07 02:11 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-09 07:09:55 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-04-07 02:11:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 Thiz; en-US; rv:1.1) Gecko/20021127

Description of problem:
pyDict is unable to display the definitions for simple words like "apple",
"cup", etc.  It turns out that, during the 0.2.5.1 to 0.3.0 transition, the
iconv runs were incomplete: some of the original Big5 [acklmqsuvw].lib had
errors, and iconv only converted part of these files to UTF-8, i.e. truncated
them.  Thanks to my friend Tung Tak-Fu for the detailed analysis.

I have then went ahead and fixed these errors, and at the same time merged some
other fixes from the pydict-0.2.5.1 package that I maintain for Debian.  The
fixed [a-z].lib files are available at:

    http://anthony.homelinux.net/~foka/pydict/
or  http://210.3.115.98/~foka/pydict/

Thanks!

Anthony Fok


Version-Release number of selected component (if applicable):
pyDict-0.3.0

How reproducible:
Always

Steps to Reproduce:
1. Open pyDict (0.3.0 series)
2. Search for "apple".  Not found!
3. Look in /usr/share/pydict/a.lib

Additional info:

Comment 1 Leon Ho 2003-04-09 07:09:55 UTC
Thanks for your report Anthony! Applied and pydict-0.3.0-5 contains the fix. 


Note You need to log in before you can comment on or make changes to this bug.