Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88144 - Upgrading to RedHat 9 causes all mailing list archives to point to http://porky.devel.redhat.com/...
Summary: Upgrading to RedHat 9 causes all mailing list archives to point to http://por...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailman
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-06 20:15 UTC by H. Peter Anvin
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-24 15:15:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:179 normal SHIPPED_LIVE Mailman RPM does not properly handle package installation and upgrade. 2003-09-24 04:00:00 UTC

Description H. Peter Anvin 2003-04-06 20:15:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
The shipped Mailman/Defaults.py contains:

DEFAULT_EMAIL_HOST = 'porky.devel.redhat.com'
DEFAULT_URL_HOST = 'porky.devel.redhat.com'

After doing an upgrade from RedHat 8.0, this causes *ALL* mailing list archive
links to point to http://porky.devel.redhat.com/... instead of using the web URL
that is assigned to each mailing list.  I have worked around this by adding in
Mailman/mm_cfg.py:

DEFAULT_EMAIL_HOST='zytor.com'
DEFAULT_URL_HOST='www.zytor.com'
add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

... however, that is less desirable than the previous situation since it will no
longer point to the correct vhost.

Version-Release number of selected component (if applicable):
mailman-2.1-8

How reproducible:
Always

Steps to Reproduce:
1. Set up a Mailman server on RedHat 8
2. Upgrade to RedHat 9
3. Fix the problems described in bug 88083
4. Go to http://<host>/mailman/listinfo/<listname>
5. Click on the archive link
    

Actual Results:  Attempt to open http://porky.devel.redhat.com/pipermail/...

Expected Results:  Attempt to open http://<host>/pipermail/...

Additional info:

Comment 1 Jean-Baptiste Vignaud 2003-04-10 21:29:09 UTC
I have fixed 88083 on my upgraded server and i have some more information on
this problem:

I have two lists on my server; one list is public, it's name is displayed with
http://<host>/mailman/listinfo/ 
the other is private and does not appear.

I reproduce the problem only with the public list. The private one is working
fine and leads to
http://<host>/mailman/private/<listname>/


Comment 2 SEKINE Tatsuo 2003-04-24 03:13:32 UTC
The reason of this problem is that
  /var/mailman/Mailman/mm_cfg.py is NOT marked as config file.

Please run the command below:
  $ rpm -q --qf \
    "[%{FILENAMES} (%{FILEFLAGS:fflags})\n]" mailman \
    | grep mm_cfg

The result should be
  /var/mailman/Mailman/mm_cfg.py (cn)
where "c" means "config" and "n" mesans "noreplace",
but we obtain
  /var/mailman/Mailman/mm_cfg.py ()

The spec file shoud have
  %attr(0644, root, mailman) %config(noreplace) \
  %verify(not md5 size time) %{_var}/mailman/Mailman/mm_cfg.py
entry.

Obviously this CRITICAL bug cause many problems.
- Updating destroy old configuration.
- Verifying of package will fail always.
- etc.


Comment 3 John Dennis 2003-09-24 19:18:33 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-179.html



Note You need to log in before you can comment on or make changes to this bug.