Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88139 - /etc/logrotate.d/named causes e-mail to be sent during log rotation
Summary: /etc/logrotate.d/named causes e-mail to be sent during log rotation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-06 17:19 UTC by Jordan Russell
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-07 20:04:50 UTC


Attachments (Terms of Use)

Description Jordan Russell 2003-04-06 17:19:59 UTC
Description of problem:
After upgrading to Red Hat Linux 9, I just got this e-mail today...

-------------------------------------------------------
Subject: Cron <root@hostname> run-parts /etc/cron.daily

/etc/cron.daily/logrotate:

Reloading named: [60G[  [0;32mOK[0;39m  ]
-------------------------------------------------------

The problem is in /etc/cron.daily/logrotate. It redirects stderr to /dev/null 
but not stdout.

To fix, this line:

        /sbin/service named reload  2> /dev/null || true

should be changed to:

        /sbin/service named reload  >/dev/null 2> /dev/null || true


Version-Release number of selected component (if applicable):
bind-9.2.1-16

Comment 1 Daniel Walsh 2003-04-07 20:04:50 UTC
It will be fixed in the next release of bind.

Dan


Note You need to log in before you can comment on or make changes to this bug.