Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88117 - init script overrides config file
Summary: init script overrides config file
Keywords:
Status: CLOSED DUPLICATE of bug 76051
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-06 01:51 UTC by Brandon Davis
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:30 UTC


Attachments (Terms of Use)

Description Brandon Davis 2003-04-06 01:51:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207
Phoenix/0.5

Description of problem:
If the datadir for mysql is changed in /etc/my.cnf the new datadir is ignored
because it is overriden by the the datadir defined in /etc/rc.d/init.d/mysqld.
If I change the datadir in /etc/my.cnf when I restart mysqld it should use the
new datadir, but the command that is generated by the script overrides the
option that I define in /etc/my.cnf.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a directory /mysql
2.cp -R /var/lib/mysql/ /mysql
3.chown -R mysql:mysql /mysql
4.edit /etc/my.cnf to use the /mysql for datadir
5.restart mysqld

Actual Results:  /sbin/service mysqld status
returns: mysqld dead but subsys locked


Expected Results:  mysql should be running and should be using /mysql for the
datadir

Additional info:

if the variable datadir in /etc/rc.d/init.d/mysqld is changed to be /mysql then
it will work, but I shouldn't have to change this. It should  just use what I
defined in the config file.

Comment 1 Patrick Macdonald 2003-04-07 13:00:33 UTC
This is a duplicate of an enhancement request.  We're currently looking into
it.  Dup of 76051

*** This bug has been marked as a duplicate of 76051 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:30 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.