Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88110 - Spamassassin init script sets wrong subsys flag
Summary: Spamassassin init script sets wrong subsys flag
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: spamassassin
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
: 104671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 20:45 UTC by Brian Landers
Modified: 2007-04-18 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 21:37:23 UTC


Attachments (Terms of Use)

Description Brian Landers 2003-04-05 20:45:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
In the init script for spamassassin (spamd), the "start" option touches the
subsys flag "spamd" but the "stop", and "condrestart" options look for the flag
"spamassassin"

  start)
        ...
        [ $RETVAL = 0 ] && touch /var/lock/subsys/spamd

  stop)
        ...
        [ $RETVAL = 0 ] && rm -f /var/lock/subsys/spamassassin

  condrestart)
        [ -e /var/lock/subsys/spamassassin ] && $0 restart



Version-Release number of selected component (if applicable):
spamassassin-2.44-11.8.x

How reproducible:
Always

Steps to Reproduce:
1. edit /etc/init.d
2. observe that the subsys flags are different
    

Additional info:

Comment 1 Matthew Lenz 2003-04-07 12:57:04 UTC
I've got the same problem.  Going into runlevel 1 (# init 1) leaves spamassissin
running and when returning (# exit) to the previous runlevel (in my case 5)
spamassissin fails to start because it is already running.

Comment 2 Chip Turner 2003-04-07 13:11:49 UTC
this should be fixed in spamassassin-2.50-4.8.x.i386.rpm, which is in rawhide

Comment 3 Warren Togami 2004-02-29 06:19:11 UTC
*** Bug 104671 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.