Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88103 - Crystal cs4237b is not properly detected by setup
Summary: Crystal cs4237b is not properly detected by setup
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 18:48 UTC by Yi S. Ding
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-29 20:57:36 UTC


Attachments (Terms of Use)

Description Yi S. Ding 2003-04-05 18:48:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I did a clean install of Redhat 9 on a Dell Precision 410.  After doing so, I
ran first boot, and kudzu ran, and detected my sound card and printer.  However,
after launching Redhat, the sound driver refused to work.  The sound card on
this machine is an onboard cs4237b.  Also, at shutdown, it also displays errors
with regard to the soundcard.  I encountered this problem in both Redhat 9 and
8.0 but not in 7.3.  The soundcard detection software in Redhat 9 and 8.0 also
claims I have no soundcard although it works perfectly on other OSes I've tried
(RH 7.3, Win XP, Knoppix)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot the Dell 410
2. Start Redhat.
3. Start XMMS.

Actual Results:  XMMS has no sound.

Expected Results:  It should have sound.

Additional info:

Comment 1 Bill Nottingham 2003-04-07 21:20:23 UTC
What error messages do you get from the driver?

Comment 2 Yi S. Ding 2003-04-08 02:30:41 UTC
When starting KDE, arts complains there is no /dev/dsp and redirects output to
/dev/null.  When shutting down, one job fails because it can not find the sound
slot 0.  Also, redhat-config-soundcard claims it cannot detect any soundcard.

Comment 3 Bill Nottingham 2003-04-08 15:15:32 UTC
redhat-config-soundcard doesn't support ISA cards.

Is there an alias for sound-slot-0 in /etc/modules.conf?

What messages do you get in 'dmesg' after running 'modprobe sound-slot-0'?

Comment 4 Yi S. Ding 2003-04-09 23:53:50 UTC
There's two lines regarding a sound card in /etc/modules.conf
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

modprobe returns modprobe: Can't locate module sound-slot-0

dmesg only says:

isapnp: Scanning for PnP cards...
isapnp: Card 'CS4236B'
isapnp: 1 Plug & Play card detected total

However, after I do modprobe sound-slot-1:
ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
ad1848: WSS/SB detected
ad1848: ISAPnP reports 'WSS/SB' at i/o 0x534, irq 5, dma 1, 3

Comment 5 Yi S. Ding 2003-04-09 23:57:55 UTC
Clarification:  the last set of messages were after I ran dmesg after modprobe
sound-slot-1 and the second to last set were before I ran modprobe sound-slot-1
and were near the top of the dmesg list.

Comment 6 Yi S. Ding 2003-04-26 02:45:50 UTC
After downloading sndconfig and running it, it changed the modules.conf to the
correct values.  Everything seems to work now.  I'm still confused as to why
kudzu didn't detect the sound card properly.

Comment 7 Bill Nottingham 2005-03-29 20:57:36 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.


Note You need to log in before you can comment on or make changes to this bug.