Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88098 - multiple (5) applets in KDE Panel after upgrade
Summary: multiple (5) applets in KDE Panel after upgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 17:16 UTC by stuart boreen
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-07 20:10:57 UTC


Attachments (Terms of Use)
png screenshot of KDE panel (deleted)
2003-04-05 17:17 UTC, stuart boreen
no flags Details

Description stuart boreen 2003-04-05 17:16:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
There are now 5 rhn applets on my kde task bar.
I installed RH8 and use KDE, then I upgraded to RH9 and got 5 applets in my panel.
First I had to add rhn-applet to the KDE autostart file in RH8 because you don't
start it in KDE. See bug #74712


Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.9.0.1

How reproducible:
Didn't try

Steps to Reproduce:
1.Install RH 8
2.Switch to KDE desktop and add rhn applet to .kde autostart folder.
3. Upgrade to rh 9 and use KDE
4. If I remove rhn-applet from .kde autostart I still get 5 applets!
    

Actual Results:  I get 5 applets with a blue check.

Expected Results:  Should have 1 applet.

Additional info:

Comment 1 stuart boreen 2003-04-05 17:17:59 UTC
Created attachment 90926 [details]
png screenshot of KDE panel

This shows my KDE panel after RH9 upgrade.

Comment 2 Owen Taylor 2003-04-07 15:14:54 UTC
I believe that adding the applet to the autostart file is the cause
of your problem. The autostart file is meant for applications that
don't support the normal session management protocol, so won't be
restarted normally.

But the applet _does_ handle session management, so its presence
in the autostart folder means that another applet gets added each
time.

If it didn't show up after the upgrade, simply running the program
once should be sufficient to fix that. 

So, remove all but one applet, remove it from the autostart folder
and I think things will work correctly on subsequent logins.
b

Comment 3 Daniel Veillard 2003-09-07 20:40:44 UTC
Okay thanks !

Daniel


Note You need to log in before you can comment on or make changes to this bug.