Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88097 - rpm becomes useless when removing glibc
Summary: rpm becomes useless when removing glibc
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 9
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 16:19 UTC by Need Real Name
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-17 14:33:59 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-04-05 16:19:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
when removing glibc (yes this happened to me because i wanted to be sure i had
the i686 version and not the i386), rpm being not statically linked is rendered
useless, which means you get in trouble in reinstalling the wanted package



Version-Release number of selected component (if applicable):
rpm-4.2-0.69

How reproducible:
Always

Steps to Reproduce:
1. rpm -e glibc --nodeps
2. rpm -Uvh glibc-....-i686.rpm
3.
    

Actual Results:  can't load library .....so

Expected Results:  installing newer glibc

Additional info:

"easy but nasty" workaround:  from another computer, extract the library files
required and the sash shell,    then (you need to have an already mounted nfs
share), run shash, copy the files to /lib, and reinstall the needed glibc

Comment 1 Warren Togami 2003-04-06 04:47:12 UTC
You should NEVER remove glibc.  If you want to install the same version of glibc
of a specific arch:
rpm -Uvh glibc*.i686.rpm --force

You can query the arch of the installed package like this.
rpm -q --qf %{ARCH} glibc

Lots of people want statically linked rpm, but that should be its own
discussion.  File a separate RFE and/or talk on shrike-list or rpm-list. 

I recommend this CLOSED NOTABUG.

Comment 2 Jeff Johnson 2003-04-17 14:33:59 UTC
/usr/lib/rpm/rpmi is statically linked like /bin/rpm used to be.
(/bin/rpm can no longer be statically linked for other reasons.)


Note You need to log in before you can comment on or make changes to this bug.