Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88089 - Text-mode configurator doesn't allow for cups browsing, sharing, etc
Summary: Text-mode configurator doesn't allow for cups browsing, sharing, etc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 115930 156952 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 14:59 UTC by David Krider
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-06 10:04:50 UTC


Attachments (Terms of Use)

Description David Krider 2003-04-05 14:59:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When using redhat-config-printer-tui, there are no options for allowing the
printers to be printed-to over the network or browsed, as in the -gui version.
This ability should be added for people who don't use X on their print servers.

Also, it would be nice to put in the ability -- in both versions -- to allow for
remote administration (by adding a "Listen" directive to open it up to more than
just the localhost).


Version-Release number of selected component (if applicable):
redhat-config-printer-gui-0.6.47-1

How reproducible:
Always

Steps to Reproduce:
Run redhat-config-printer-tui, or redhat-config-printer in the absence of X.

Additional info:

Comment 1 Tim Waugh 2003-04-05 15:07:43 UTC
(Remote administration part split off to bug #88090.)

Comment 2 Thomas Dodd 2003-04-08 15:14:14 UTC
If you hand edit /etc/alchemist/namespace/printconf.adl to put the share option
in, printconf-tui doesn't remove them, and printconf-backend will still use them
to generate cupsd.conf correctly. See post on shrike-list for format.

Comment 3 Tim Waugh 2003-04-08 16:20:07 UTC
For that matter you can use 'printconf-tui --Ximport' too..

Comment 4 Tim Waugh 2004-02-17 12:31:04 UTC
*** Bug 115930 has been marked as a duplicate of this bug. ***

Comment 5 Thomas M Steenholdt 2004-02-18 10:01:22 UTC
Should this functionality not be put into the -tui tool ? for reasons
why this might be a good idea, see Bug 115930

Comment 6 W. Michael Petullo 2005-01-22 23:13:11 UTC
The printconf tui tool still does not seem to allow one to configure
printer shares like the gui tool does.  This is true as of
system-config-printer-0.6.119-1.

Comment 7 Tim Waugh 2005-05-05 17:27:28 UTC
*** Bug 156952 has been marked as a duplicate of this bug. ***

Comment 8 W. Michael Petullo 2006-02-16 01:44:21 UTC
I have a headless server that automatically configures USB printers when they
are attached.  However, the generated printer configurations do not share the
printers.  It would be nice if a global configuration could activate sharing.

The following command:

printconf --Xadd-local --model="XXX" --device="/dev/usb/lp0" --make="YYY"
--name="ZZZ"

world work as it currently does except that "Listen x.x.x.x" and "Allow From
y.y.y.y." would be included in the cupsd.conf that is generated.

I can see that system-config-printer's backend.py writes out the printer
configuration.  Could it first read, for example, /etc/sysconfig/printconf, and
look for a "share" flag?  Or perhaps printconf_tui.py could do something similar?



Comment 9 Tim Waugh 2006-02-16 09:40:59 UTC
See comment #3 -- you can import the XML configuration directly.  First, set up
the queue as you would like them to appear using the graphical tool; then save
the configuration using 'printconf-tui --Xexport'.

Later, you can restore the configuration using 'printconf-tui --Ximport'.

Comment 10 W. Michael Petullo 2006-02-16 15:13:06 UTC
In comment #8, I am talking about being able to plug a printer into a printer 
server and have it work and share without any user intervention.  Setting up 
the printer by hand and exporting / importing the configuration does not meet 
my criteria.

Comment 11 Tim Waugh 2006-02-16 16:29:04 UTC
In the next-generation printer administration tool, this will be possible with a
global setting I think.  In /etc/cups/cupsd.conf, having a '<Location
/printers>' will affect all newly created queues formed by connecting a printer.

Comment 12 W. Michael Petullo 2006-02-16 19:37:50 UTC
That's exactly what I am looking for.  Thanks, Tim.

Comment 13 W. Michael Petullo 2006-07-06 02:28:54 UTC
Can anyone confirm or deny that this "global setting" feature is in
system-config-printer-0.7.19?  If not, is anyone aware of plans for it?

Comment 14 Tim Waugh 2006-07-06 10:04:50 UTC
This is now controlled by the CUPS 'DefaultShared' configuration directive in
/etc/cups/cupsd.conf.  The default is for new printers to be shared.


Note You need to log in before you can comment on or make changes to this bug.