Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88087 - KDM and XDM Freeze on logout on inspiron 4150
Summary: KDM and XDM Freeze on logout on inspiron 4150
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 14:19 UTC by Dennis Gilmore
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-12 11:47:18 UTC


Attachments (Terms of Use)
My X Config file (deleted)
2003-04-06 08:50 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2003-04-05 14:19:50 UTC
Description of problem: 
When using KDM or XDM as my login manager the machine locks up.  it logs out of everything 
and seems to be about to restart the login screen and the screen stays black.  i have tried this 
on a desktop machine here with a cirrus logic chipset and it works fine  but on the laptop with a 
radeon 7500 it doesnt work.  GDM will work but if i log out of kde with gdm i can not shutdown 
or reboot the machine directly, i have to go to the login promt and shutdown/reboot from there.   
 
i think it is a XFree86 bug as i got the exact same error with mandrake 9.1 on this machine, 
and a desktop i have here that i compiled kde 3.1.1 on that has a radeon 7000 card works fine. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Change display manager to KDM or XDM 
2. login  
3.logout 
     
Actual results: 
Machine Locks up 
 
Expected results: 
KDM or XDM to give a new login prompt 
 
Additional info:

Comment 1 Mike A. Harris 2003-04-06 05:47:12 UTC
If you completely disable your sound card, by unconfiguring the kernel
modules, does this problem go away?  Please test that, reboot, and
let me know if it changes anything or not.

This might be a duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=87544


Comment 2 Dennis Gilmore 2003-04-06 08:50:37 UTC
Created attachment 90932 [details]
My X Config file

Comment 3 Dennis Gilmore 2003-04-06 08:54:41 UTC
XDM and KDM both still lock up with sound disabled.  i dont think its the same as bug 87544 
as GDM works  

Comment 4 Mariah Waterland 2003-04-10 06:07:43 UTC
This same bug appears when using KDM on the Dell Optiplex GX 260.

Comment 5 Dennis Gilmore 2003-05-12 11:47:18 UTC
I have updated to XFree86-4.3.0-8  and i can now logout with KDM.  I think its a
similiar to bug 87544  but not quite the same .  But its now resolved.


Note You need to log in before you can comment on or make changes to this bug.