Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88082 - gnome-dictionary annoyance: window opens for no reason
Summary: gnome-dictionary annoyance: window opens for no reason
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 08:39 UTC by J.B. Nicholson-Owens
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-07-19 09:40:23 UTC


Attachments (Terms of Use)

Description J.B. Nicholson-Owens 2003-04-05 08:39:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have the gnome dictionary installed in my GNOME panel so I can type in a word
and look it up.  When I login there is an empty gnome-dictionary window opened
by this applet (as if I were trying to look up "", the empty string).

This did not happen in RH8.0 and I don't understand what the point of the empty
dictionary window is.

Version-Release number of selected component (if applicable):
Due to another bug I can't retreive the version of the gnome-dictionary applet.
 It is the version that comes with RH9.

How reproducible:
Always

Steps to Reproduce:
1.Put gnome-dictionary on your GNOME panel.
2.Log out and save the settings for GNOME.
3.Log back in.

Actual Results:  A definition window is opened when I log in.

Expected Results:  The applet on the panel should load but not open a window for
showing me the definition of a word until I type in a word to define.

Additional info:

gnome-dictionary installed itself on my GNOME panel to run as "gnome-dictionary
-a".  The -a is undocumented so I don't know what it means and I did not modify
the option in any way.

Comment 1 Havoc Pennington 2003-04-05 16:29:19 UTC
Do you have a gnome-dictionary saved in your session? 
(Look in gnome-session-properties or in the file ~/.gnome2/session)

Comment 2 J.B. Nicholson-Owens 2003-04-07 04:18:48 UTC
I do have a gnome-dictionary saved in my session (as instructed, I looked in the
file ~/.gnome2/session and found some dictionary entries:

$ grep -i gnome-dictionary ~/.gnome2/session
2,Program=gnome-dictionary
2,CloneCommand=gnome-dictionary --sm-config-prefix /gnome-dictionary-cSP2q3/
2,RestartCommand=gnome-dictionary --sm-config-prefix /gnome-dictionary-cSP2q3/
--sm-client-id 117f000001000104968748300000029060000 --screen 0

I lose the dictionary entries in that file when I remove the dictionary lookup
input area+lookup button from my GNOME panel.

Also I have no idea what to do with this file to make the dictionary window stop
coming up when I log in.  I'm also at a loss for documentation that explains the
behavior I'm seeing.  And finally, I don't understand why I did not see this
behavior when I did the same thing under RH8.0 (adding the GNOME dictionary
prompter to my panel did not prompt me when I logged in).

Comment 3 Havoc Pennington 2003-04-07 05:34:06 UTC
It looks like it might be http://bugzilla.gnome.org/show_bug.cgi?id=101508

The reason it wasn't in 8.0 and isn't in the docs is that it isn't intentional 
behavior.

There was a fix for applets connecting to the session manager added to 9
(the problem with applets connecting was introduced by a bonobo-activation 
change also in 9), but gnome-dictionary may work differently from the 
other applets since it has the small application associated with it
so perhaps it didn't get fixed.

Comment 4 J.B. Nicholson-Owens 2003-04-07 11:38:28 UTC
Thanks for clearing that up for me.  I checked out the GNOME Bugzilla and that
is indeed the same problem.  Thanks for pointing me to that entry.  I'll leave
it to someone who knows more than I do how to close this bug and make it a
duplicate of a bug on another Bugzilla.

Comment 5 Mark McLoughlin 2004-07-19 09:40:23 UTC
Okay, sounds like this is fixed in Fedora Core 1/2. Please re-open if not.


Note You need to log in before you can comment on or make changes to this bug.