Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88080 - Customising keyboard with xmodmap stopped working
Summary: Customising keyboard with xmodmap stopped working
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 08:29 UTC by vigna
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-01 21:45:31 UTC


Attachments (Terms of Use)

Description vigna 2003-04-05 08:29:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
With RH 9 something fundamental changed in the way the X keyboard is handled,
leading to incompability with previous setups. I could not find anything in the
Release Notes about this, so I think it will be a problem.

I am using since years an .Xmodmap file which contains lines as

keycode  34 = egrave eacute bracketleft braceleft

This is an absolute necessity if you use an Italian keyboard, as having braces
on 0/7 is a disaster when you program or use TeX.

This worked from RH 3 throughout RH 8. In RH 9, the resulting behaviour is that
the corresponding key does not emit anything beyond egrave and eacute (i.e., it
even stops emitting bracketleft when using AltGr).

Apparently, it is no longer possible to customise the keyboard with xmodmap.
Please provide an alternative solution.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run xmodmap -e "keycode  34 = egrave eacute bracketleft braceleft" on a
system with Italian keyboard
2. Try to write a "["

    

Additional info:

Comment 1 Mike A. Harris 2003-04-05 10:45:53 UTC
xkb has had significant changes in XFree86 4.3.0, which cause some types
of configuration to change.  Wether or not what you are doing is one of them,
I don't know as I'm not an xkb expert.

If there is a problem, it definitely is not a Red Hat induced problem.  It
would be a generic XFree86 problem.  The best thing to do, is to file a bug
report in XFree86.org's bugzilla instead, which the xkb maintainer and other
experts in this area will receive, and will be able to assess the alleged
problem much easier and provide an answer.

Once you've done that, please provide a link here to that bug report and
I will track the upstream progress.

Moving bug to UPSTREAM status.

Comment 2 vigna 2003-04-05 11:24:17 UTC
You're right. Indeed I filed a very long bug report
(http://bugs.xfree86.org//cgi-bin/bugzilla/show_bug.cgi?id=109) on the overall
assignments of the Italian keyboard, which need some rethinking.

I'll point them here for the specific xmodmap problem.


Comment 3 Mike A. Harris 2003-05-21 11:22:50 UTC
This problem is fixed in upstream CVS and I will backport the changes into
rawhide, and future erratum.  Thanks for reporting and tracking it there.

Comment 4 Mike A. Harris 2003-08-16 14:40:52 UTC
Backported fixes applied to 4.3.0-19 in rawhide.  Closing bug as MODIFIED.
Please test the new release and change bug status to RAWHIDE if it works, or
ASSIGNED if the problem persists.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.