Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88075 - Installing Galeon and/or mozilla-chat makes gnome-dictionary half vanish
Summary: Installing Galeon and/or mozilla-chat makes gnome-dictionary half vanish
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-utils
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 07:46 UTC by J.B. Nicholson-Owens
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-06 15:10:55 UTC


Attachments (Terms of Use)

Description J.B. Nicholson-Owens 2003-04-05 07:46:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Originally I wanted to report an annoyance with gnome-dictionary--it opens up
its dictionary window when I login just because I've got the dictionary prompter
loaded on my GNOME panel.  So I fired up Mozilla and visited the RH Bugzilla site.

I was waiting for the RH Bugzilla to open and I decided to install Galeon and
mozilla-chat while I waited.  I figured there was no interference with
this--loading a webpage shouldn't interfere with installing a couple apps.  I
began to install both apps from the Add/Remove Applications application and
there was no sign of trouble.

As that was installing, the Bugzilla webpage was rendering and I went to type
the rpm instruction into the shell to learn what version of gnome-dictionary I
was dealing with.  RPM told me gnome-dictionary couldn't be found.  The exact
RPM returned data is below.

But gnome-dictionary IS installed--it is still on my system and I can run it
from the command line (but now it does not annoyingly open the window when I run
"gnome-dictionary" or "gnome-dictionary -a" like the GNOME panel does).  The
mozilla-chat and Galeon install completed without incident.

So I'm at a loss on what to say about this.  Is this an RPM bug?  A
gnome-dictionary bug?  A Galeon or mozilla-chat package bug?  Multiple bugs?

Version-Release number of selected component (if applicable):
4.2-0.69

How reproducible:
Didn't try (the problem is hard for me to reproduce)

Steps to Reproduce:
1. I installed RH9 workstation and told the installer to wipe out all partitions.
2. I updated the system from up2date.
3. I saw the annoying gnome-dictionary behavior and (on a completely unrelated
activity) installed mozilla-chat and Galeon from Add/Remove Applications.
4. gnome-dictionary disappears from system as far as RPM is concerned, but the
gnome-dictionary application still runs (thus introducing an inconsistency
between what's on the system and what's in RPM's database).

Actual Results:  gnome-dictionary disappeared from the RPM list of what's
installed in the system (see "rpm -qif" and "rpm -q" returns below).

Expected Results:  I expected gnome-dictionary to remain untouched.  After all,
what does installing Galeon or mozilla-chat have to do with gnome-dictionary?

Additional info:

The lack of sync between the RPM database and what's on my system makes me quite
uneasy.  I can't trust the system to handle installing or removing packages
anymore because the list of what's installed is untrustworthy.

Here's what RPM told me when I asked it to tell me about gnome-dictionary:

$ rpm -qif gnome-dictionary
error: file gnome-dictionary: No such file or directory
$ rpm -q gnome-dictionary
package gnome-dictionary is not installed

gnome-dictionary remains installed as far as I can tell: I can run it and the
man page for gnome-dictionary is still installed.

Comment 1 Jeff Johnson 2003-04-14 15:01:11 UTC
rpm manages packages, not files.

Did you install gnome-dictionary form a package or
did you install the files through some other means?

Comment 2 J.B. Nicholson-Owens 2003-04-14 21:28:29 UTC
I can only assume gnome-dictionary was installed with RH9 in the "workstation"
set of packages.  I did nothing to indicate I wanted it, I merely installed RH9
and it was there.

When I installed galeon and mozilla-chat I noticed the package for
gnome-dictionary had disappeared from RPMs catalog of installed packages.  I
don't know why gnome-dictionary's entry in RPM's database vanished.  The files
for gnome-dictionary are still installed on the system because I'm running
gnome-dictionary in my GNOME panel right now.  But the package data is gone
("rpm -qi gnome-dictionary" says "package gnome-dictionary is not installed". 
By contrast "rpm -qi mozilla" gives me info about mozilla's entry in the RPM
database).

Comment 3 Jeff Johnson 2003-04-17 14:41:44 UTC
I don't see an rpm problem here, so I'm reassigning to
gnome-utils in case there is a packaging problem with
/usr/share/gnome/help/gnome-dictionary handling.

Comment 4 Alexander Larsson 2003-10-06 15:10:55 UTC
gnome-dictionary is part of the package gnome-utils. rpm -q gnome-utils should
work for you. Or rpm -qf /usr/bin/gnome-dictionary.


Note You need to log in before you can comment on or make changes to this bug.