Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88068 - If playlist or Equalizer in focus, xmms will not minimize by clicking on panel icon
Summary: If playlist or Equalizer in focus, xmms will not minimize by clicking on pane...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 05:46 UTC by Philip Wyett
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-29 12:16:56 UTC


Attachments (Terms of Use)

Description Philip Wyett 2003-04-05 05:46:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:

If xmms playlist or equalizer are the in focus windows. You cannot click on it's
icon on the Gnome panel and get it to minimize. This method does work if it is
the Media Player Window itself in focus. Also right clicking on the icon on the
gnome panel and clicking on minimize works correctly, no matter which of the 3
windows is in focus.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

If xmms playlist or equalizer are the in focus windows. You cannot click on it's
icon on the Gnome panel and get it to minimize. This method does work if it is
the Media Player Window itself in focus. Also right clicking on the icon on the
gnome panel and clicking on minimize works correctly, no matter which of the 3
windows is in focus.
    

Actual Results:  Cannot minimize via xmms gnome panel icon if the playlist or
equalizer window is the one in focus.

Expected Results:  Should minimize whichever window is in focus, as it did under
RH 8.0.

Additional info:

Comment 1 Bill Nottingham 2003-04-07 21:25:20 UTC
Havoc: which window bits is it not doing right that would cause this to fail in
9 and not 8.0?

Comment 2 Havoc Pennington 2003-04-07 21:49:37 UTC
No idea - probably an interaction bug rather than a straightforward "not doing 
things right" would have to play metacity logfile.

Comment 3 Colin Walters 2004-09-27 19:47:13 UTC
I can reproduce this with FC3 devel.

Comment 4 Matthias Saou 2005-11-29 12:16:56 UTC
I can't reproduce in FC4 with the xmms from Extras : With the playlist window
in focus, left clicking on the xmms entry from the window list in the GNOME
panel minimizes all of xmms properly.


Note You need to log in before you can comment on or make changes to this bug.