Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88064 - Mozilla progress download dialog always on top and cannot be minimized
Summary: Mozilla progress download dialog always on top and cannot be minimized
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 03:47 UTC by Philip Wyett
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-05 16:07:11 UTC


Attachments (Terms of Use)

Description Philip Wyett 2003-04-05 03:47:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:

1. From mozilla's file menu do: Edit->Preferences

2. After 'Preferences' dialog box is open select: Navigator->Downloads

3. Select option: Open a progress dialog

4. Click on Ok, to finalize and leave the 'Preferences' dialog.

5. Attempting to download a file from the internet and as the download
   is progressing, attempt to minimize the dowload progress dialog
   or bring the main maximized mozilla window above does nothing.

Version-Release number of selected component (if applicable):
mozilla-1.2.1

How reproducible:
Always

Steps to Reproduce:
1. From mozilla's file menu do: Edit->Preferences

2. After 'Preferences' dialog box is open select: Navigator->Downloads

3. Select option: Open a progress dialog

4. Click on Ok, to finalize and leave the 'Preferences' dialog.

5. Attempt to download a file from the internet and as the download
   is progressing, attempt to minimize the dowload progress dialog
   or bring the main maximized mozilla window above it.

Actual Results:  The download progress dialog will always stay on top of the
main mozilla window and is unable to be minimized.

Expected Results:  The download progress dialog should be able to loose focus in
favor of the main mozilla window. Also a download dialog should be able to be
minimized.

Additional info:

Comment 1 Christopher Blizzard 2003-05-05 16:07:11 UTC
I tested this and I haven't seen any problems.  I'm also testing off of a trunk
build, though so I'll mark it as NEXTRELEASE since we'll pick up this version next.

Comment 2 Justin Georgeson 2003-09-15 16:52:25 UTC
Have a look at this bug in Mozilla's bugzilla. 

http://bugzilla.mozilla.org/show_bug.cgi?id=204671

Somewhere in 1.2 is where it started showing up in builds from mozilla.org, but
the RH 1.2 RPMs didn't have the problem. I just upgraded to the 1.4.0-12 RPMs in
rawhide on my RH 9 box, and they do have this problem.

Comment 3 Justin Georgeson 2003-09-16 05:49:35 UTC
This also happens in the latest firebird, but it is a metacity issue. I loaded
sawfish and the problem went away.


Note You need to log in before you can comment on or make changes to this bug.