Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88063 - request for netfs to start after ybind
Summary: request for netfs to start after ybind
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 03:04 UTC by G Sandine
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-07 21:38:20 UTC


Attachments (Terms of Use)

Description G Sandine 2003-04-05 03:04:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3) Gecko/20030327
Debian/1.3-4

Description of problem:
We have many workstations that use hostname NFS mounts, with /etc/hosts
supplemented by NIS.  NFS hostname (rather than IP address) mounts fail when the
host IP address is provided by NIS, because netfs is linked at S25 while ypbind
is linked as S27.  We move rc?.d/S25netfs to rc?.d/S29netfs in all of our
workstations so we are free to move the NFS and NIS servers around and have host
to IP info coming from NIS and have successful NFS (hostname in fstab) mounts,
without having to update /etc/hosts in every client.

Version-Release number of selected component (if applicable):
7.14-1

How reproducible:
Always

Steps to Reproduce:
1. Put hostname NFS mount entries in /etc/fstab for a client, without specifying
host to IP map in the client's hosts file.
2. Make portmap, nfslock, netfs, and ypbind start at boot.
    

Actual Results:  NFS mounts are attempted prior to starting ypbind, and they
fail due to inability to locate host (by name).

Expected Results:  This should work, rather than having to resort to DNS or to
manually update hosts file in multiple clients.

Additional info:

Suggested fix is to link netfs to S2x (x > 5), so it comes after S25, which
links to ypbind.

Comment 1 G Sandine 2003-04-05 03:08:18 UTC
Braino in the additional subject -- we would like netfs to start _after_ ypbind.

Comment 2 Bill Nottingham 2003-04-07 21:26:19 UTC
The issue here is that currently the ypbind init script relies on programs in
/usr, which could be mounted via NFS, which leads to circular dependencies.

Comment 3 G Sandine 2003-04-07 21:38:20 UTC
Right, I did not think about that.  We'll just swap netfs and ypbind starts and
stops here since it works better for us that way.

Perhaps start ypbind in the netfs initscript (only if necessary and possible
[i.e. /usr is available] -- I'm not sure how to check the "necessary" part),
then exit the ypbind initscript straightaway if ypbind is already running.  It's
awfully convenient for us to be able to move around the NFS and NIS servers
without having to update local host tables.  Actually, it seems resorting to
(local) DNS would be better than hacking on initscripts.

Thank you.



Note You need to log in before you can comment on or make changes to this bug.