Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88062 - TTF Fonts + OpenOffice = Crashing
Summary: TTF Fonts + OpenOffice = Crashing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-05 02:54 UTC by Tom Jackson
Modified: 2007-04-18 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-27 16:16:49 UTC


Attachments (Terms of Use)

Description Tom Jackson 2003-04-05 02:54:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
After adding additional TTF fonts to OpenOffice with the oopadmin tool Open Office begins to crash at various spots.  I have tested this on two different machines (one athlon the other i686).  Either you get the following crash on startup

[foo@home foo]$ oowriter
Checking for existing user installation ...   ...   NOT FOUND
Performing first-time installation for user ...   /usr/bin/ooffice: line 197: 12677 Segmentation fault      /usr/lib/openoffice/program/setup -R:/etc/openoffice/autoresponse.conf
...   FAILED

Or oowriter starts properly but crashes as soon as you attempt to select a different font.

I have removed all OpenOffice RPMS and reinstalled.  Same behavior continues.

Version-Release number of selected component (if applicable):
openoffice-1.0.2-4

How reproducible:
Always

Steps to Reproduce:
1.Add additional TTF fonts to OpenOffice with the oopadmin command (as root)
2.Start oowriter as root or user. (get crash)
3.If no crash try changing fonts. (get crash)
    

Expected Results:  Same procedure under RH 8.0 works fine.

Additional info:

Comment 1 Bruce Garlock 2003-04-10 20:33:35 UTC
I'm having the same issue I think.  I upgraded to RH 9 from RH 8.  I couldn't
even launch mozilla after the upgrade to RH 9, until I started removing all
fonts that have been added to my system over the years, trying to leave only the
default fonts installed by RH 9.  I had a lot of different font directories,
which I am cleaning up.  After doing that, I was able to launch mozilla, but I
am still unable to even launch OO.

I have removed my .openoffice directory, and I get the same error you reference
above when starting OO.



Comment 2 Bruce Garlock 2003-04-10 22:53:15 UTC
After installing the glibc update for RH9, things seem much better.  

Comment 3 Tom Jackson 2003-04-13 01:53:26 UTC
I continue to have the same problems after updating glibc 

Comment 4 Bruce Garlock 2003-04-13 12:10:10 UTC
I really think this is font related.  I "cleaned up" all the fonts on my system,
by seeing which ones were installed from RPM's, and which ones were not.  I
spent some time going through all the different directories where fonts were
installed, and did a rpm -qf `ls` in each directory.  If the directory was not
from an RPM, I deleted or moved it somewhere else.  Then I reran fc-cache and OO
started working again, but not until I did all the up2date packages.  It really
made a difference for me after the glibc update.  I couldn't even run xmms
before the glibc update.  My system had been upgraded from previous redhat
releases, and this was the first upgrade that was rough.

Was your system upgraded or a 'fresh' install?

Comment 5 Tom Jackson 2003-04-14 11:06:51 UTC
In my case it's a fresh install. 

Comment 6 Bruce Garlock 2003-04-14 13:32:03 UTC
Ouch.  I figured maybe you were in the same boat as me, with an upgrade. 
Anything on usenet about this?  

Comment 7 Jeremiah Jahn 2003-04-14 14:19:16 UTC
I'm having the same problem on a fresh install. Useing the laptop/home desktop
install off of the dvd.

Comment 8 Mohamed Kamil Nizam 2003-04-23 05:46:47 UTC
I face same problem when I add new TTF fonts. It happen after I install using 
openoffice setup printer dialog box. After I run oowriter and click to choose 
font, oowriter crash. This also happen if I install into one of TTF directory 
listed using chkfontpath. This problem didn't happen on RH8.0. I don't know the 
problem from openoffice or XFS.

Comment 9 Tom Jackson 2003-04-24 23:20:20 UTC
Thought it might be xfs.  I downloaded the latest openoffice.org (1.0.3.1) and installed it.  
Installed the TTF fonts and it functions fully.   

Comment 10 Dan Williams 2004-02-27 16:16:49 UTC
Please try current OOo 1.1.0, and reopen if problem still occurs


Note You need to log in before you can comment on or make changes to this bug.