Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88048 - Missing line in drivers/pci/pci.ids
Summary: Missing line in drivers/pci/pci.ids
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: pciutils
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 21:26 UTC by Glen A. Foster
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-04 23:42:35 UTC


Attachments (Terms of Use)

Description Glen A. Foster 2003-04-04 21:26:58 UTC
Description of problem: Running "lspci" on my HP i2000 (Itanium-1, a "big sur" 
class system), I find a device that's unknown.  HP would really like to have 
this fixed since this is a core hardware device for this system.

The line:

04:14.1 Host bridge: Intel Corp.: Unknown device 84ea

... comes from missing this line:

84ea  460GX - 84460GX AGP Bridge (GXB function 1)

in "drivers/pci/pci.ids".  As verified on the e.25 kernel, that's the only 
obvious 460GX device ID they're missing.

Version-Release number of selected component (if applicable):
# rpm -q kernel pciutils
kernel-2.4.18-e.27
pciutils-2.1.8-26

How reproducible: 100% (always)

Steps to Reproduce:
1. Install on an HP i2000
2. Login as root
3. run "lspci | grep -i unknown"

Actual results:
# lspci | grep -i unknown
04:14.1 Host bridge: Intel Corp.: Unknown device 84ea

Expected results:
No "unknown" devices listed.

Comment 1 Glen A. Foster 2003-04-04 21:27:49 UTC
... if anaconda is wrong (probably is), please forward to whomever.  I started 
with anaconda, BTW, because it finds PCI devices just like lspci.

Comment 2 Bill Nottingham 2003-04-04 22:54:06 UTC
This does not affect functionality in any way.

Comment 3 Glen A. Foster 2003-04-04 22:57:39 UTC
Please re-consider.  It looks bad for HP customers to have anything reported by 
Red Hat Linux saying "I don't know what this hardware is".  It's a one-line 
patch and I've provided the information necessary.

Comment 4 Glen A. Foster 2003-04-04 23:00:20 UTC
... or at least mark it DEFERRED instead WONTFIX?

Comment 5 Bill Nottingham 2003-04-04 23:42:35 UTC
Deferred sounds ok... it should be fine in AS3.


Note You need to log in before you can comment on or make changes to this bug.