Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88035 - Cannot install mysql on a new system from the cd's
Summary: Cannot install mysql on a new system from the cd's
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 20:07 UTC by bobt
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-08 14:45:13 UTC


Attachments (Terms of Use)

Description bobt 2003-04-04 20:07:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
Cannot install mysql because of circular references of needing perl(CGI)
and perl-DBD-mysql which need libmysqlclient.so.10 which is in the mysql rpm. 
Did someone really try to install this package after a basic install. Or is this
an APRIL FOOLS joke that I don't get.
to test take cd 2 and install mysql from the rpm packages on a machine with a
basic install.



Version-Release number of selected component (if applicable):
mysql-3.23.54a-11

How reproducible:
Always

Steps to Reproduce:
1.use RedHat 9 cd #2
2.rpm -Uvh mysql*
3.solve dependancies without using anything not on the cd.
    

Actual Results:  Packages will NOT install

Expected Results:  It should install it always has in the past

Additional info:

Comment 1 Patrick Macdonald 2003-04-04 21:35:19 UTC
If you are using command line rpm, you have to install the dependent packages.
That said, all packages that mysql* is dependent on are on disc2.

Here's the output from an rpm install on a clean system.  As you state, there
are failed dependencies which you have to resolve.  This sequence of commands
was issued using only disc2 of the distro.

[root@tower RPMS]# rpm -Uvh mysql*
error: Failed dependencies:
        perl(DBI) is needed by mysql-3.23.54a-11
        perl-DBD-MySQL is needed by mysql-3.23.54a-11
        perl-DBI is needed by mysql-3.23.54a-11
    Suggested resolutions:
        perl-DBD-MySQL-2.1021-3.i386.rpm
        perl-DBI-1.32-5.i386.rpm

[root@tower RPMS]# rpm -Uvh mysql* perl-DBI* perl-DBD-MySQL*
Preparing...                ########################################### [100%]
   1:perl-DBI               ########################################### [ 20%]
   2:mysql                  ########################################### [ 40%]
   3:mysql-devel            ########################################### [ 60%]
   4:mysql-server           ########################################### [ 80%]
   5:perl-DBD-MySQL         ########################################### [100%]


Is there something I am missing in your complaint?

My output is a little different than yours because I installed rpmdb-redhat-9.
It's helpful when trying to track down failed dependencies.


Comment 2 Patrick Macdonald 2003-04-08 14:45:13 UTC
Marking this as not a bug.


Note You need to log in before you can comment on or make changes to this bug.