Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88033 - r128 high res Xv playback results in green noise
Summary: r128 high res Xv playback results in green noise
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 20:04 UTC by Mike A. Harris
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-05 01:30:49 UTC


Attachments (Terms of Use)
XFree86-4.3.0-ati-r128-Xv-ecp-divisor.patch (deleted)
2003-04-04 20:05 UTC, Mike A. Harris
no flags Details

Description Mike A. Harris 2003-04-04 20:04:03 UTC
Description of problem:
When using a Rage 128 in a high resolution images displayed with the
XVideo extension have weird "green" noise in them

Version-Release number of selected component (if applicable):
4.3.0-2

How reproducible: 100%

Comment 1 Mike A. Harris 2003-04-04 20:05:45 UTC
Created attachment 90909 [details]
XFree86-4.3.0-ati-r128-Xv-ecp-divisor.patch

Date: Mon, 31 Mar 2003 10:58:45 -0500
From: Rik Faith <faith@alephnull.com>
To: devel@xfree86.org
Reply-To: devel@XFree86.Org
Content-Type: text/plain; charset=us-ascii
Subject: Xvideo patch for R128
 
[I didn't see anything specific for patches on
http://www.xfree86.org/mailman/listinfo (and I haven't been keeping
track of the recent list changes), so I hope this is ok to post here.]
 
Here is a patch against XFree86 4.3.0 (from the xf-4_3_0 cvs tag).
 
The problem is that at high screen resolutions (i.e., with a high
dot-clock), if the ECP divisor is set wrong, images displayed with the
XVideo extension have weird "green" noise in them (vertical green static
that appears to be "over" or "between" the pixels).  Alternatively, if
the ECP divisor was somehow set correctly before XFree86 4.3.0 starts
(e.g., with Windows or GATOS), then the symptom is that only the left
half (or third) of the image is displayed when using Xvideo (because
h_inc is computed wrong).
 
Thanks, Rik Faith

Comment 2 Mike A. Harris 2003-04-05 01:30:49 UTC
Patch applied to 4.3.0-3.3

Comment 3 Rik Faith 2003-04-07 16:37:16 UTC
This patch has been checked into the XFree86 CVS tree (by Kevin Martin).


Note You need to log in before you can comment on or make changes to this bug.