Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88019 - PalmOS USB hotsync IDs missing
Summary: PalmOS USB hotsync IDs missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 18:03 UTC by Need Real Name
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-07 16:08:22 UTC


Attachments (Terms of Use)
Output from dmesg (deleted)
2003-04-07 15:15 UTC, Need Real Name
no flags Details
/var/log/messages entry when CLIE is connected (deleted)
2003-04-07 15:17 UTC, Need Real Name
no flags Details
Output for /proc/bus/usb/devices (deleted)
2003-04-07 15:19 UTC, Need Real Name
no flags Details
/var/log/messages entry when CLIE MS-Import is connected (deleted)
2003-04-07 15:30 UTC, Need Real Name
no flags Details
/proc/bus/usb/devices when CLIE MS-Import is connected (deleted)
2003-04-07 15:31 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-04-04 18:03:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030403

Description of problem:
HotSync of Sony CLIE used to cause the "visor" kernel module to automatically
load.  After "upgrading" to RH9, a HotSync attempt now produces the following in
the messages log:

kernel: usb.c: USB device 2 (vend/prod 0x54c/0x66) is not claimed by any active
driver.


Version-Release number of selected component (if applicable):
hotplug-2002_04_01-17

How reproducible:
Always

Steps to Reproduce:
1.Install RH9
2.Connect Sony CLIE USB cable and choose HotSync in PalmOS
3.Notice in the messages log that RH9 failed to support the USB
manufactor/vendor code for auto-loading the "visor" 
    

Actual Results:  kernel: usb.c: USB device 2 (vend/prod 0x54c/0x66) is not
claimed by any active driver.

Expected Results:  Expected 0x54c/0x66 to auto-load usbserial & visor kernel modules
Like RH8 does:
  /etc/hotplug/usb.agent: Setup visor for USB product 54c/66/100

Additional info:

jpilot v0.99.5 fixes some bugs which occationally cause databook entries to be
lost.  So, of course RH9 continues to distribute...
   jpilot 0.99.2 with a known databook data lost issue

but has a patch for...
   the configure and Makefile which doesn't correct the databook issue at all

NICE!  Maybe the hotplug issue is a feature instead of a bug to at least
preserve the integraty of the databook... at least until the batteries give out.

Comment 1 Pete Zaitcev 2003-04-04 21:07:40 UTC
Please connect Clie, then copy output of dmesg, /var/log/messages,
/proc/bus/usb/devices, and attach them to the bug.
PLEASE DO NOT DROP THEM INTO THE COMENTS BOX.

Comment 2 Need Real Name 2003-04-07 15:15:55 UTC
Created attachment 90954 [details]
Output from dmesg

Comment 3 Need Real Name 2003-04-07 15:17:39 UTC
Created attachment 90955 [details]
/var/log/messages entry when CLIE is connected

Comment 4 Need Real Name 2003-04-07 15:19:13 UTC
Created attachment 90956 [details]
Output for /proc/bus/usb/devices

Comment 5 Need Real Name 2003-04-07 15:30:20 UTC
Created attachment 90957 [details]
/var/log/messages entry when CLIE MS-Import is connected

Comment 6 Need Real Name 2003-04-07 15:31:48 UTC
Created attachment 90958 [details]
/proc/bus/usb/devices when CLIE MS-Import is connected

Comment 7 Need Real Name 2003-04-07 15:36:11 UTC
The first messages & devices files are when the CLIE HotSync application is
running which under RH8 causes usbserial & visor kernel modules to automatically
load.  Under RH9, only if the modules are manually loaded does hotsync'ing work.

The problem also effects accessing the CLIE Memory Stick.  The second messages &
devices file pair are when the CLIE MS-Import application is running which under
RH8 causes usb-storage module to automatically load.  Again, under RH9 if the
module is manually loaded then the memory stick can be mounted as expected.

Comment 8 Need Real Name 2003-04-07 16:08:22 UTC
Nevermind.  /proc/sys/kernel/hotplug was set to /bin/true
Fix was:
  echo "/sbin/hotplug" > /proc/sys/kernel/hotplug

I'm still trying to figure out what changed the status since this isn't in my
/etc/sysctl.conf


Note You need to log in before you can comment on or make changes to this bug.