Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 88003 - gnome-panel color not saved across sessions; reverts to black
Summary: gnome-panel color not saved across sessions; reverts to black
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 15:03 UTC by Steven Usdansky
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-06 21:44:27 UTC


Attachments (Terms of Use)

Description Steven Usdansky 2003-04-04 15:03:23 UTC
Description of problem:
if gnome panel background type is set to color and a color is selected, panel
color reverts to black upon restart of gnome

Version-Release number of selected component (if applicable): gnome-panel-2.2.0.1-9


How reproducible: always


Steps to Reproduce:
1. Bring up panel properties dialog, select background tab
2. Change type to Color, select a color (I selected red - #D94747)
3. Close dialog
4. Log out of GNOME
5. Log back in to GNOME
    
Actual results:
black panel background

Expected results:
red panel background


Additional info:
Session preference is set to save changes to session

Comment 1 Mike Vanecek 2003-04-08 17:07:45 UTC
I am seeing the same problem.

Comment 2 eitelman 2003-04-28 14:44:52 UTC
I am having the same problem. The steps to reproduce above do not show selecting
"Save current setup" on logout dialog box. But even when this is done, the color
comes back as black.

I submitted this as a service ticket to Red Hat Installation Support (#233703)
and they were unable to reproduce the problem on the lab machine. So maybe this
is a hardware related problem. I am using an nVidia GeForce2 MX with 32 MB of
video ram on an eVga.com video card. 

Steve Eitelman
eitelman@erols.com

Comment 3 eitelman 2003-04-28 14:47:12 UTC
Oops sorry Steven - I did not see the Additional Info - save session above. My
mistake!

Comment 4 Havoc Pennington 2003-04-28 16:56:06 UTC
The bug is fixed upstream: http://bugzilla.gnome.org/show_bug.cgi?id=107401

This isn't an installation or hardware issue, just a software bug.

Should be sure we have the fix in the next release.

Comment 5 Mike Vanecek 2003-04-28 17:17:26 UTC
Will RedHat put out a up2date on this?  If not, how do I get the fix and 
install it?



Comment 6 Havoc Pennington 2003-04-28 18:35:02 UTC
An update for this is very unlikely, as there are many higher-priority items
in the queue in front of it. To get a fix you would have to get the SRPM and 
integrate the patch yourself, or build all of GNOME from source in a separate
prefix.

Comment 7 Havoc Pennington 2003-08-06 21:44:27 UTC
We've built latest gnome-panel in rawhide now.


Note You need to log in before you can comment on or make changes to this bug.