Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87983 - devlabel does not work with cdrom units
Summary: devlabel does not work with cdrom units
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: devlabel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 10:08 UTC by David Balažic
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-21 23:13:53 UTC


Attachments (Terms of Use)

Description David Balažic 2003-04-04 10:08:31 UTC
Description of problem:

devlabel is more or less unusable with (IDE) CD-ROM units.
It either works or fails with different error messages.

My system :

hde : Teac CD-532E-B , 32x CD-ROM
hdg : Teac CD-W540E  , 40x12x48x CD-MRW

devlabel results :

(hdg has a CD inserted,but not mounted, hde is empty) :

[root@slave6 label]# devlabel  add -d /dev/hdg -s $PWD/cdx
Created symlink /dev/label/cdx -> /dev/hdg
[root@slave6 label]# devlabel  add -d /dev/hde -s $PWD/cdy

/dev/hde does not exist.
Failure.  Since this device does not exist, it did not return an identifier.


( no CD inserted in either drive ) :

[root@slave6 ide]# devlabel  add -d /dev/hde -s $PWD/cde

Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.
[root@slave6 ide]# devlabel  add -d /dev/hdg -s $PWD/cdg

/dev/hdg does not exist.
Failure.  Since this device does not exist, it did not return an identifier.

And ( CD in both drives , both mounted ) :

[root@slave6 mnt]# devlabel  add -d /dev/hde -s $PWD/cde

Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.
[root@slave6 mnt]# devlabel  add -d /dev/hdg -s $PWD/cdg

Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.

And finally, CD in both, none mounted :

[root@slave6 mnt]# devlabel  add -d /dev/hde -s $PWD/cde

Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.
[root@slave6 mnt]# devlabel  add -d /dev/hdg -s $PWD/cdg

Failure.
The device you are trying to add to devlabel does not show up in


Version-Release number of selected component (if applicable):
devlabel-0.26.08-3
kernel-2.4.20-8.athlon.rpm

Comment 1 Bill Nottingham 2004-09-08 19:50:22 UTC
Please try to reproduce on a current release (FC1/FC2).


Note You need to log in before you can comment on or make changes to this bug.