Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87976 - Named daemon will not shutdown after executing /etc/init.d/named stop
Summary: Named daemon will not shutdown after executing /etc/init.d/named stop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On: 85896
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-04 07:52 UTC by S. Eerkes
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-18 17:34:11 UTC


Attachments (Terms of Use)

Description S. Eerkes 2003-04-04 07:52:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Yesterday i upgraded 2 machines and installed 1 from scratch
1 from RedHat 7.3 to RedHat 9.0
1 from RedHat 8.0 to RedHat 9.0
1 clean install from RedHat 9.0
on all machine's i can't stop the named process by typing 
/etc/init.d/named stop kill the process is working fine (normal kill)
starting the named daemon with /etc/init.d/named start
is also working fine, how to solve this problem
i think the problem is in the "/usr/sbin/rndc" program
which will be executed from the /etc/init.d/named script


Version-Release number of selected component (if applicable):
bind-9.2.1-16

How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/named stop
2. ps -ef|grep named
3. 
    

Actual Results:  the named daemon was still running

Expected Results:  the named daemon should be not running anymore

Additional info:

version: bind-9.2.1-16 (RedHat 9.0 + latest patches 'up2date')

[root@smarthost root]# /etc/init.d/named stop
Stopping named:
[root@smarthost root]# /usr/sbin/rndc stop
[root@smarthost root]# ps -ef|grep named
named     2098     1  0 08:15 ?        00:00:00 [named]
root     10993 10933  0 09:47 pts/0    00:00:00 grep named
[root@smarthost root]#

Comment 1 Nathan G. Grennan 2003-04-07 04:21:44 UTC
I see this also.

Comment 2 Nathan G. Grennan 2003-04-07 04:31:11 UTC
I upgraded to bind-9.2.2-8 from rawhide and still see this problem.

Comment 3 Nathan G. Grennan 2003-04-07 05:03:19 UTC
Apr  7 05:00:07 localhost named[19069]: app.c:562: unexpected error:
Apr  7 05:00:07 localhost named[19069]: isc_app_shutdown() pthread_kill: No such
process

Got this in the logs after "service named stop".

This is even after trying recompiling(9.2.2-8) it on the machine.

Comment 4 Nathan G. Grennan 2003-04-07 05:58:34 UTC
I was able to get it to shutdown by recompiling without --enable-threads

I still don't get a proper OK from the stop though. It just says

Stopping named:

Comment 5 Daniel Walsh 2003-04-07 19:19:40 UTC
Yes we know about this problem, but it is Kernel related.  Basically there is a
thread signalling problem in the Kernel.  So when the named recieves the thread
shutdown kernel it goes into a weird state.  We have to wait for the errata
kernel to fix this problem.

Dan

Comment 6 Daniel Walsh 2003-04-07 19:20:43 UTC
85896  Is the bug description that causes this problem.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=85896

Comment 7 S. Eerkes 2003-04-07 20:32:23 UTC
i've got a message saying

You are not authorized to access bug #85896.

how can i see this ?

Comment 8 Daniel Walsh 2003-04-07 20:47:43 UTC
Get a job at Red Hat :^)

I changed the permission so you should be able to see it now.

Dan

Comment 9 Nathan G. Grennan 2003-04-09 03:04:53 UTC
I can confirm that kernel-2.4.20-9 fixes my issue with the actual shutdown of
named when using service named stop.

Comment 10 S. Eerkes 2003-04-17 14:02:15 UTC
when stopping the deamon with new kernel it's stopping
only there is no [OK] sign

Comment 11 Nathan G. Grennan 2003-04-17 15:11:13 UTC
That problem has already been reported in another bug report, 87527.

Comment 12 S. Eerkes 2003-04-17 18:26:59 UTC
the line is not erased at start as discribed in problem 87527
but when manual stopping /etc/init.d/named stop then there is no [OK] sign
but the named is stopped

Comment 13 Daniel Walsh 2003-04-18 17:34:11 UTC
It works in bind-9.2.2-10.

Dan


Note You need to log in before you can comment on or make changes to this bug.