Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87944 - keytable: mapscrn: cannot open map file _iso15_ error at boot
Summary: keytable: mapscrn: cannot open map file _iso15_ error at boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 22:07 UTC by Tom Wood
Modified: 2007-04-18 16:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-27 01:37:31 UTC


Attachments (Terms of Use)
Fix to /sbin/setsysfont as discussed above. (deleted)
2004-01-17 15:35 UTC, Davide Bolcioni
no flags Details | Diff

Description Tom Wood 2003-04-03 22:07:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
keytable warnings at boot timeApr  3 17:02:53 fluid 
generated at boot time.

Version-Release number of selected component (if applicable):
kbd-1.08-4

How reproducible:
Always

Steps to Reproduce:
1.Boot RH9.
2.Watch for "keytable: mapscrn: cannot open map file _iso15_ error" at boot
    

Additional info:

Comment 1 Mace Moneta 2003-04-16 18:59:49 UTC
I'm seeing the same problem at boot.  Is there any functional impact resulting
from this message (none noticed)?

Comment 2 Alfredo 2003-04-19 11:30:07 UTC
I have the same error message at boot, and the resulting problem is that I don't
have accented characters and the euro symbol in the console of my spanish
system. I think that kbd-1.08-4 is not packing iso15 fonts. The error can be
triggered if you have:

SYSFONTACM="iso15"

in /etc/sysconfig/i18n




Comment 3 Need Real Name 2003-04-22 02:26:54 UTC
1) Upgraded from Redhat8. Bug not present in Redhat8.
2) Causes some man pages to fail ("man getrusage").
3) Other fonts missing in Redhat9
   Apr 21 22:07:19 library modprobe: modprobe: Can't locate module char-major-188
   Apr 21 22:07:24 library xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/CID (unreadable) 
   Apr 21 22:07:24 library xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/local (unreadable) 
   Apr 21 22:07:24 library xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/latin2/Type1 (unreadable) 
   Apr 21 22:07:28 library modprobe: modprobe: Can't locate module char-major-81

Comment 4 Davide Bolcioni 2004-01-17 15:31:13 UTC
I chased this and I think I got it nailed down (the following applies
to Fedora Core but should apply to RedHat 9 also). The problem is not
with the kbd package but with initscripts, initscripts-7.42.2-1 on my
host, and specifically with /sbin/setsysfont.

Basically, the following fragment of /sbin/setsysfont:

  SYSFONTACM=`echo $SYSFONTACM | sed "s|iso0|8859-|g"

does not work as intended if SYSFONTACM=iso15, it works for values
from "iso01" to "iso09" only. The fix is straightforward:

  SYSFONTACM=`echo $SYSFONTACM | sed "s|iso0\?|8859-|g"

Hope this helps.

Comment 5 Davide Bolcioni 2004-01-17 15:35:08 UTC
Created attachment 97072 [details]
Fix to /sbin/setsysfont as discussed above.

Also added braces around variable substition on preceding line, for clarity
(that
threw me off at first).

Comment 6 Eido Inoue 2004-02-27 01:37:31 UTC
fixed in the initscripts in the current release


Note You need to log in before you can comment on or make changes to this bug.