Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87943 - (NET E100) e100 fail to work with Intel 82557/8/9
Summary: (NET E100) e100 fail to work with Intel 82557/8/9
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 21:54 UTC by Marek Kassur
Modified: 2013-07-03 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-18 01:23:27 UTC


Attachments (Terms of Use)
lspci -vv (deleted)
2003-04-03 21:56 UTC, Marek Kassur
no flags Details
Output of dmesg (kernel: 2.4.22-1.2174.nptl) (deleted)
2004-03-17 15:40 UTC, Marek Kassur
no flags Details

Description Marek Kassur 2003-04-03 21:54:39 UTC
Description of problem:
e100 driver output:

kernel: Intel(R) PRO/100 Network Driver - version 2.1.29-k2
kernel: Copyright (c) 2002 Intel Corporation
kernel:
kernel: e100: hw init failed
kernel: e100: Failed to initialize, instance #0

However eepro100 works just fine:

kernel: eepro100.c:v1.09j-t 9/29/99 Donald Becker
http://www.scyld.com/network/eepro100.html
kernel: eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin
<saw@saw.sw.com.sg> and others
kernel: eth0: OEM i82557/i82558 10/100 Ethernet, 00:D0:B7:B6:DB:6B, IRQ 10.
kernel:   Board assembly 000000-000, Physical connectors present: RJ45
kernel:   Primary interface chip i82555 PHY #1.
kernel:   General self-test: passed.
kernel:   Serial sub-system self-test: passed.
kernel:   Internal registers self-test: passed.
kernel:   ROM checksum self-test: passed (0x04f4518b).


How reproducible:
Always

Steps to Reproduce:
Setup network using default e100 driver.


Additional info:
e100 driver works with RedHat 7.3

Comment 1 Marek Kassur 2003-04-03 21:56:39 UTC
Created attachment 90885 [details]
lspci -vv

Comment 2 Scott Feldman 2004-03-04 04:03:05 UTC
The failure to load was probably caused by the nic not having a valid 
eeprom checksum, but I can't be sure because 2.2.21 didn't print the 
exact reason why it failed (sorry).

A newer e100 driver would print the exact failure.  This doesn't fix 
the eeprom, but does give us exact cause for the failure of the 
driver to load.  Newer e100 drivers are here: 
http://sf.net/projects/e1000.  Please try a newer version and post 
output of dmesg.

The eeprom checksum check is necessary to detect 1) manufacturing 
problems, 2) user tampering, 3) counterfeit nics.

Comment 3 Marek Kassur 2004-03-17 15:38:41 UTC
Newer driver from Fedora Core 1 works for me, maybe it was driver
problem. Output of dmesg attached.


Comment 4 Marek Kassur 2004-03-17 15:40:37 UTC
Created attachment 98607 [details]
Output of dmesg (kernel: 2.4.22-1.2174.nptl)

Comment 5 Scott Feldman 2004-03-17 19:04:05 UTC
Looks like issue can be closed.


Note You need to log in before you can comment on or make changes to this bug.