Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87929 - up2date registration cannot using to an existing account: "problem registering username"
Summary: up2date registration cannot using to an existing account: "problem registerin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 19:22 UTC by Graham Leggett
Modified: 2013-08-22 15:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-14 19:26:29 UTC


Attachments (Terms of Use)

Description Graham Leggett 2003-04-03 19:22:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3) Gecko/20030318

Description of problem:
- Run up2date on a brand new system.

- Select "existing user", and provide username and password.

- Move through wizard steps, until up2date tries to connect to rhn for the first
time.

- A popup window appears saying "problem with username".

- Sit back and wonder why on earth the lazy-ass programmer didn't mention WHAT
problem with the username.

- The account used has no free entitlements, which I assume is the problem, but
this should not prevent the registration procedure from completing, or from at
least a proper PARAGRAPH of explanatory text appearing saying exactly what is wrong.

- Did I mention that "problem with username" is one of the most STOOOPID error
messages I ever saw? (not as bad as "operation failed: success", but close).


Version-Release number of selected component (if applicable):
3.1.23-3

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:

Comment 1 Adrian Likins 2003-04-08 22:04:49 UTC
fixed in 3.1.24

Comment 2 Matt Jamison 2003-05-14 19:26:29 UTC
tested it and now it gives a much better description.

error Message:
Username 'sdfasdfas' has not been reserved
Error class code: 1
error class info: this does not appear to be a valid username.

Comment 3 Steve Dickson 2013-08-22 15:14:19 UTC
*** Bug 963148 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.