Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87921 - text mode startup: system font corrupt
Summary: text mode startup: system font corrupt
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 18:53 UTC by Graham Leggett
Modified: 2014-03-17 02:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-10 17:07:50 UTC


Attachments (Terms of Use)

Description Graham Leggett 2003-04-03 18:53:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3) Gecko/20030318

Description of problem:
- Go through a vanilla install of Redhat v9.0. Select to boot into text mode.

- Start machine for the first time. At the point where the system font is set,
the entire text console becomes corrupt. Normal ascii characters are mapped to
what look like greek and control characters. The space is mapped to some random
character. Before the system font is set, the character set is fine.

The only workaround to this is to log in blindly and start X, but otherwise text
mode is hosed. Is setsysfont really necessary at all?

The machine has a Trident Cyberblade graphics card, which was autodetected
during the X configuration.


Version-Release number of selected component (if applicable):
7.14-1

How reproducible:
Always

Steps to Reproduce:
xxxx
    

Additional info:

Comment 1 Bill Nottingham 2003-04-03 20:23:25 UTC
What locale are you using? What's the content of /etc/sysconfig/i18n?

Comment 2 Graham Leggett 2003-04-04 09:29:53 UTC
The default locale selected was "english south africa".

The contents of /etc/sysconf/i18n is:

[root@rachel root]# cat /etc/sysconfig/i18n 
LANG="en_ZA.UTF-8"
SUPPORTED="af_ZA:af:en_GB.UTF-8:en_GB:en:en_ZA.UTF-8:en_ZA:en:en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"


Comment 3 Dave Disser 2003-04-12 05:49:51 UTC
I get the same thing, my /etc/sysconfig/i18n is 

LANG=en_US

My video card is an NVidia GeForce4 MX

Comment 4 Graham Leggett 2003-07-21 23:04:10 UTC
Just to confirm: this bug is still outstanding on the most recent patched
version of Redhat v9.0, and is still just as annoying.


Comment 5 Bill Nottingham 2003-09-04 01:25:22 UTC
Hm, I've duplicated that /etc/sysconfig/i18n and I can't reproduce this. I
wonder if it's something specific to loading a screen font on that graphics
chipset. Does it happen no matter what you set SYSFONT to?

Comment 6 Graham Leggett 2003-09-10 14:34:58 UTC
We eventually ditched the motherboard and installed a different one, and the
problem went away. I think this is probably an obscure corruption with old hardware.


Comment 7 Bill Nottingham 2003-09-10 17:07:50 UTC
OK, closing as WORKSFORME (as it does).


Note You need to log in before you can comment on or make changes to this bug.