Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87895 - Solaris machines have problems when bound to RH8.0 nis slave server
Summary: Solaris machines have problems when bound to RH8.0 nis slave server
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 16:26 UTC by Need Real Name
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-18 16:14:48 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-04-03 16:26:03 UTC
Description of problem:
Solaris machines bound to RH8.0 nis server can't see automount directories

Version-Release number of selected component (if applicable):
ypserv 2.5.1

How reproducible:
always

Steps to Reproduce:
1.ypset host to one of 2 RH8.0 nis slave servers
2./etc/init.d/autofs stop;/etc/init.d/autofs start
3.ls <automounted direcotry>
    
Actual results:
ls hangs

Expected results:
ls shows files on automounted fileystems


Additional info:
This only happens on RH8.0 systems. We have 5 RH6.2 nis slave servers that work 
just fine.

Comment 1 Dennixx 2003-08-04 12:38:37 UTC
Since the update of our RedHat 7.3 NIS slave server with the latest errata we
also had some problems with the solaris clients. The wrong directory gets
mounted with automount, and the solaris client hangs in hostname and username
resolving. I verified that all maps are the same as on the nis master.

The wordaround for us was to reconfigure the solaris clients to use our Tru64
UNIX NIS master and Tru64 UNIX NIS slave server before the RedHat Linux 7.3 NIS
slave. However I expect that those Tru64 systems will be replaced by RedHat
Linux servers in a while, so this problem has to be solved!

The previous version of ypbind which works fine: ypserv-2.5-2.7x
The current version of ypbind which creates problems: ypserv-2.8-0.73E

Dennis Voetelink
ECN

Comment 2 Bill Nottingham 2006-08-07 18:51:31 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.

Comment 3 Bill Nottingham 2006-10-18 16:14:48 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.


Note You need to log in before you can comment on or make changes to this bug.