Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8789 - FrameBuffer scrambles screen
Summary: FrameBuffer scrambles screen
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 7549 7597 8287 8500 9323 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-24 05:02 UTC by Frank Sweetser
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-27 12:00:01 UTC


Attachments (Terms of Use)

Description Frank Sweetser 2000-01-24 05:02:55 UTC
When the framebuffer devices are enabled in the kernel, the screen is
constantly "snowed" in in text mode.  X is similarly scrambled, and
essentially useless.  Recompiling the kernel without framebuffer support
fixes the problem.

relevant bit of lspci -v
01:00.0 VGA compatible controller: Nvidia Corporation Riva TNT (rev 04)
	Subsystem: Unknown device 1092:0550
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
	Memory at e1000000 (32-bit, non-prefetchable)
	Memory at e3000000 (32-bit, prefetchable)
	Capabilities: <available only to root>

Comment 1 Bill Nottingham 2000-02-05 07:05:59 UTC
*** Bug 8500 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2000-02-06 06:02:59 UTC
*** Bug 7549 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2000-02-06 06:05:59 UTC
*** Bug 7597 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2000-02-06 06:24:59 UTC
*** Bug 8287 has been marked as a duplicate of this bug. ***

Comment 5 Preston Brown 2000-02-24 01:22:59 UTC
*** Bug 9323 has been marked as a duplicate of this bug. ***

Comment 6 Alan Cox 2000-08-22 14:53:18 UTC
The nvidia frame buffer + X server combination isnt supported.
Either use nvidia X and text mode or frame buffer and XFree86_fb (unaccelerated)

I believe this is supposed to get fixed by 2.4



Note You need to log in before you can comment on or make changes to this bug.