Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8787 - Sound Blaster PCI 128 (ES1371)
Summary: Sound Blaster PCI 128 (ES1371)
Keywords:
Status: CLOSED DUPLICATE of bug 5806
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-24 04:03 UTC by Darrell Long
Modified: 2014-03-17 02:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-24 05:17:01 UTC


Attachments (Terms of Use)

Description Darrell Long 2000-01-24 04:03:52 UTC
I can't get any sound with a Sound Blaster PCI 128.  This card works with
Debian (which one of my students uses), but not with RedHat 6.0.

1. sndconfig finds the card and declares it a ES1371.

2. The sox process hangs, as does play, and just about every other sound
thing (so sndconfig doesn't complete).

3. es1371: dma timed out?? -- that's what I get in the dmesg log.

4. At boot time it says:

es1371: version v0.13 time 10:41:53 Sep 27 1999
es1371: found adapter at io 0x1480 irq 10
es1371: features: joystick 0x0
es1371: codec vendor  revision 0
es1371: codec features none
es1371: stereo enhancement: no 3D stereo enhancement

5. /proc/pci says:
  Bus  0, device  15, function  0:
    Multimedia audio controller: Ensoniq ES1371 (rev 7).
      Slow devsel.  IRQ 10.  Master Capable.  Latency=96.  Min Gnt=12.Max
Lat=128.
      I/O at 0x1480 [0x1481].

6. And, of course, Windoze likes it so I know the card is OK.

I'm hoping you guys can help -- it's the first time I've asked RedHat for
support -- since I'm getting tired of buying sound cards (tried a PCI 512
before).

Thanks.

Comment 1 Bill Nottingham 2000-01-24 05:17:59 UTC
Try a 2.2.15preX kernel; the driver is fixed there.

The PCI512 should work with the em10k1 driver available
from Creative Labs.

*** This bug has been marked as a duplicate of 5806 ***

Comment 2 Bill Nottingham 2000-01-24 17:16:59 UTC
The PCI 128 you have should work with 2.2.15preX; that's where
the es1371 driver was fixed to work with the newer chipsets.


Note You need to log in before you can comment on or make changes to this bug.