Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87852 - Graphical chars displayed incorrectly with linux emulation
Summary: Graphical chars displayed incorrectly with linux emulation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses
Version: 8.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 05:43 UTC by Need Real Name
Modified: 2015-01-08 00:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-01 18:31:48 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-04-03 05:43:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
We wrote a program using python in RedHat 7.1. Our program has borders around 
the menus,etc. These borders display fine when using either linux emulation
(console) or vt100 emulation(terminals) on RedHat 7.1. We have loaded the exact 
same program on RedHat 8.0 without making any changes to the program.

On RedHat 8.0 our borders are not shown at all when using linux emulation on 
the console. When changing the emulation to vt100, the chars are displayed 
as "g"'s and other letters.

When connecting our terminals (TCP), which use vt100 emulation, to RedHat 8.0 
and running the same program, the borders are displayed fine.

It seems that the problem is with ncurses, as we use "ACS_HLINE" 
and "ACS_VLINE" in the program.

PS Noticed similar border problems in minicom. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

    

Additional info:

Comment 1 Eido Inoue 2003-08-01 18:31:48 UTC
package need to be linked/compiled against libncursesw (which is in the newer
rawhide versions of ncurses), the wide version, to work in a Unicode environment.


Note You need to log in before you can comment on or make changes to this bug.