Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87850 - Additional PLATYPUS vendor line in scsi_scan.c
Summary: Additional PLATYPUS vendor line in scsi_scan.c
Keywords:
Status: CLOSED DUPLICATE of bug 87849
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 04:51 UTC by Peter Miller
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:27 UTC


Attachments (Terms of Use)
Additional PLATYPUS vendor line for scsi_scan.c (deleted)
2003-04-03 05:18 UTC, Peter Miller
no flags Details | Diff

Description Peter Miller 2003-04-03 04:51:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
RedHat Linux 7.3

I work for Platypus Technology.  We make solid state storage devices.
Our testing indicates that an additional vendor line is required in 
drivers/scsi/scsi_scan.c, a patch is attached.

Without this patch, "scsi: READ CAPACITY: failure" error messages frequently 
occur when attempting to scan Platypus QikLINK firbre channel devices.

Version-Release number of selected component (if applicable):
2.4.18-3

How reproducible:
Always

Steps to Reproduce:
1. install FC HBA and Platypus QikLINK product
2. without the patch, attempt to load your fibre channel device driver module
3. examine /var/log/messages, you will see "scsi: READ CAPACITY: failure" error 
messages from the scsi_mod module.
    

Expected Results:  No error should appear.
All LUNs should appear in /proc/scsi/scsi

Additional info:

Patch:
--- scsi_scan.c-orig    Wed Mar 26 11:19:39 2003
+++ scsi_scan.c Wed Mar 26 11:29:41 2003
@@ -173,6 +173,7 @@
        {"IBM", "AuSaV1S2", "*", BLIST_FORCELUN},
        {"IBM", "3542", "*", BLIST_FORCELUN},
        {"DELL", "PV-136T-FC", "*", BLIST_FORCELUN},
+       {"PLATYPUS", "CX5", "*", BLIST_SPARSELUN | BLIST_LARGELUN},

        /*
         * Must be at end of list...

Comment 1 Peter Miller 2003-04-03 05:18:30 UTC
Created attachment 90860 [details]
Additional PLATYPUS vendor line for scsi_scan.c

Comment 2 Alan Cox 2003-06-08 14:55:53 UTC
Queued in current upstream submission to maintainer


Comment 3 Tom Coughlan 2003-07-23 18:13:02 UTC

*** This bug has been marked as a duplicate of 87849 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.