Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87840 - slcurses does not display line drawing characters
Summary: slcurses does not display line drawing characters
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slang
Version: 9
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2003-04-03 01:21 UTC by Richard Henderson
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-02-19 19:48:22 UTC

Attachments (Terms of Use)

Description Richard Henderson 2003-04-03 01:21:16 UTC
Description of problem:
slcurses does not display line drawing characters.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Display threads in mutt.
Actual results:
  26 N   Apr 02 Jakub Jelinek   (   0) ELIMINATE_COPY_RELOCS problems on ppc
  27 N   Apr 03 Alan Modra      (   0) >
  28 N   Apr 03 Alan Modra      (   0)   >

Expected results:
  26 N   Apr 02 Jakub Jelinek   (   0) ELIMINATE_COPY_RELOCS problems on ppc
  27 N   Apr 03 Alan Modra      (   0) mq>
  28 N   Apr 03 Alan Modra      (   0)   mq>

  where 'm' and 'q' are in xterm's "alternate char set", which
  renders them as lower-left-corner and horizontal-line respectively.

Comment 1 Bill Nottingham 2003-04-03 17:35:34 UTC
What locale are you in?

Comment 2 Richard Henderson 2003-04-03 19:53:31 UTC
C, aka unset LANG.  (I hate the dictionary sorting ls does in a language locale.)

A curious followup here is that (1) this worked with a previous version of
slang, such that mutt in rh7.1 worked, (2) I had recompiled mutt for rh9 to
use ncurses, which displayed things properly, and (3) *both* versions fail
to display the graphics characters when ssh'ed in with TERM=linux instead
of TERM=xterm.

Comment 3 Bill Nottingham 2003-04-03 20:24:38 UTC
In order to support unicode, slang was changed to actually pay attention to the

When LANG=C, the line drawing characters fail isprint() tests.

Comment 4 Bill Nottingham 2003-06-13 20:31:08 UTC
Whoa, slcurses is screwed up. You're lucky it doesn't segfault, actually. Fixing...

Comment 5 Bill Nottingham 2003-06-13 20:33:50 UTC
Although, that won't solve the isprint() issues, I believe.

Comment 6 Richard Henderson 2003-06-13 22:22:43 UTC
Then, clearly, slang should be extended to remember which characters are
supposed to be in the alternate graphics character set, and then isprint
should NOT be applied to such characters.

Comment 7 Eido Inoue 2004-02-19 19:48:22 UTC
fixed in current release

Note You need to log in before you can comment on or make changes to this bug.