Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87779 - gnome-terminal eats-up the cpu
Summary: gnome-terminal eats-up the cpu
Keywords:
Status: CLOSED DUPLICATE of bug 81018
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 13:00 UTC by G. Bersano
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:26 UTC


Attachments (Terms of Use)

Description G. Bersano 2003-04-02 13:00:55 UTC
Description of problem:
gnome-terminal consumes 64% of CPU time (34% goes to X)

Version-Release number of selected component (if applicable):
RedHat 8.0, gnome-terminal-2.0.1-5

How reproducible:
Always.

Start the RH 8.0 wokstation (actually a Compaq Presario 1800 laptop) with Gnome
Desktop; activate an xterm with "top" on an xterm, lauch gnome-terminal, and the
idle process become 0.0% (from 98%); cpu time is consume

Steps to Reproduce:
1. Start the RH 8.0 wokstation (actually a Compaq Presario 1800 laptop) with
Gnome Desktop
2. activate "top" on an xterm
3. look at the idle time (mine is 98%)
4. lauch gnome-terminal
5. observe the xterm

 
Actual results:
the idle time becomes 0.0% (from 98%); cpu time is consumed totally by
gnome-terminal+X 


Expected results:
never had problems with gnome-terminal


Additional info:
The problem appeared recently, probably after an upgrade; I suspect the
offending package could be from glibc-2.2.93-5 to glibc-2.3.2-4.80 but not sure
about this.

Comment 1 G. Bersano 2003-04-03 09:11:09 UTC
Aaargh, I should have searched better !
As explained in #81018 upgraded vte (vte-0.10.25-1.i386.rpm from RawHide), made
a symbolic link (/usr/lib/libvte.so.2 -> /usr/lib/libvte.so.4) to make
gnome-terminal-2.0.1-5 happy and all is fine again.

*** This bug has been marked as a duplicate of 81018 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.