Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87772 - halt script segfaults during forced unmounting
Summary: halt script segfaults during forced unmounting
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL: N/A
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 09:53 UTC by Hiroshi Iwatani
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 17:38:31 UTC


Attachments (Terms of Use)

Description Hiroshi Iwatani 2003-04-02 09:53:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
The reboot/halt process reports a segfault at the /etc/init.d/halt
script line 168 when the user of an unmounted filesystem is
'kernel'. Then, the reboot/halt process hangs indefinitely. We
have no choice but resetting the machine. We believe this might
be caused from the fuser -k -m command at the line 164 of the
script because the command would have killed the 'kernel' process!?
Or, has he entered an infinite loop at the line 154-168?

Version-Release number of selected component (if applicable):
6.95-1

How reproducible:
Always

Steps to Reproduce:
1.Make the remaining user of an unmounted filesystem the 'kernel' process (I
don't know how to do it!).
2.Reboot or halt.
3.
    

Actual Results:  The reboot/halt process indefinitely hangs after reporting a
segfault
at the line 168 of the halt script.


Expected Results:  That the reboot/halt process be normally executed till their
ends.

Additional info:

Sometimes mounted filesystem can't be unmounted because the
umount reports Device Busy and the fuser reports that
current only remaining user of the filesystem is kernel.
I don't know why and how this could happen. If the ramaining
user is the kernel, above phenomenon occurs. This shoud be
a fatal error on the part of the init script.

Comment 1 Bill Nottingham 2003-09-04 01:21:13 UTC
This sounds like mount/umount segfaulting.

Comment 2 Elliot Lee 2003-09-05 17:59:18 UTC
Maybe one filesystem is mounted in a subdirectory of another mounted filesystem, or 
maybe the filesystem is NFS exported.

I need more information on reproducing this problem - anything you can provide would be 
helpful.


Note You need to log in before you can comment on or make changes to this bug.