Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87765 - process become hanged
Summary: process become hanged
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: pdksh
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 07:50 UTC by Luis Domingos
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-08 11:53:37 UTC


Attachments (Terms of Use)

Description Luis Domingos 2003-04-02 07:50:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
If we have the command top running in one tcp/ip session, for instance putty or 
windows telnet,and if we close the window, the process loose the tty and starts 
consuming a lots of CPU and put the processor down.These kind of behaviour is 
also seen with other programs, like for instance rmcobol.

I discovered that the problem is related with ksh (pdksh), if the user's shell 
is bash, I don't have these problems.

This is a issue related with abnormal program termination.

The version of pdksh is pdksh-5.2.14-13.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.In a windows box do a telnet to linux
2.Run top
3.Close the window
4.wait 5 minutes and telnet to linux
5. do a ps -ef | grep top, and you will see top consuming the CPU
    

Expected Results:  1. The process top should no exists.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.