Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87763 - hpoj detect printer but does not initialize
Summary: hpoj detect printer but does not initialize
Keywords:
Status: CLOSED DUPLICATE of bug 82652
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hpoj
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 04:25 UTC by Mike Basinger
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:26 UTC


Attachments (Terms of Use)

Description Mike Basinger 2003-04-02 04:25:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have gotten hpoj to detect my HP OfficeJet K80xi (usb), but the hpoj service
will not initialize.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run service hpoj setup
2. detect printer
3. save settings
4. try to start hpoj
    

Actual Results:  hpoj starts

Expected Results:  Stopping the HP OfficeJet Linux driver.
 
----------------------------------------------------------------------
 
This program manages devices controlled by the HP OfficeJet Linux
driver (hpoj).  It attempts to probe your computer for local parallel-
and USB-connected devices, and allows you to specify network addresses
for remote JetDirect-connected devices.
 
If you experience any difficulties in detecting your device(s), then
refer to the hpoj documentation for troubleshooting information.
 
----------------------------------------------------------------------
 
Currently defined device names ([*]=default):
    *** The following devices are using an obsolete configuration
    *** file format.  Use "/etc/init.d/hpoj setup"
    *** to delete and re-probe them:
    --> "mlc:usb:OfficeJet_K80xi"
 
Press <Enter> alone to continue, or if you would like to delete
or reconfigure one of the above-listed devices, then enter the
device name to delete here --->
 
----------------------------------------------------------------------
 
Probe for parallel-connected devices ([y]/n)?  n
 
----------------------------------------------------------------------
 
Probe for USB-connected devices ([y]/n)?  y
 
Probing "/dev/usb/lp0"...
    Found "OfficeJet  K80xi"
    with serial number "MY2A9D61XVOH".
 
    This device will be set up as "mlc:usb:OfficeJet_K80xi".
    Press <Enter> alone to continue or <Ctrl-D> to skip this device, or
    enter a different desired name suffix (without the "mlc:usb:" prefix)
    here --->
 
    Setting up as "mlc:usb:OfficeJet_K80xi".
    Enabling ptal-mlcd and ptal-printd.
 
Probing "/dev/usb/lp1"...
    No device found.
 
Probing "/dev/usb/lp10"...
    No device found.
 
Probing "/dev/usb/lp11"...
    No device found.
 
Probing "/dev/usb/lp12"...
    No device found.
 
Probing "/dev/usb/lp13"...
    No device found.
 
Probing "/dev/usb/lp14"...
    No device found.
 
Probing "/dev/usb/lp15"...
    No device found.
 
Probing "/dev/usb/lp2"...
    No device found.
 
Probing "/dev/usb/lp3"...
    No device found.
 
Probing "/dev/usb/lp4"...
    No device found.
 
Probing "/dev/usb/lp5"...
    No device found.
 
Probing "/dev/usb/lp6"...
    No device found.
 
Probing "/dev/usb/lp7"...
    No device found.
 
Probing "/dev/usb/lp8"...
    No device found.
 
Probing "/dev/usb/lp9"...
    No device found.
 
----------------------------------------------------------------------
 
Press <Enter> alone to continue, or if you would like to add a
JetDirect-connected device, then enter its dotted-decimal
IP address or hostname here --->
 
----------------------------------------------------------------------
 
Currently defined device names ([*]=default):
    *** The following devices are using an obsolete configuration
    *** file format.  Use "/etc/init.d/hpoj setup"
    *** to delete and re-probe them:
    --> "mlc:usb:OfficeJet_K80xi"
 
A system-wide default device name is not currently defined.
 
Press <Enter> alone to continue with no default,
or enter a new default device name here --->
 
----------------------------------------------------------------------
 
Done updating device configuration files stored under /etc/ptal.
If you make manual changes to those files, then be sure to run
"/etc/init.d/hpoj start" so they will take effect.
 
----------------------------------------------------------------------
 
Starting the HP OfficeJet Linux driver.
    No hpoj devices have been configured.
    As root, run "/etc/init.d/hpoj setup".


Additional info:

I only get hpoj to detect my printer after editing /etc/sysconfig/i18n and
change LANG from en_US.UTF-8 to en_US 
from 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=82652

Comment 1 Tim Waugh 2003-04-02 10:12:58 UTC
This is caused by a perl bug.

*** This bug has been marked as a duplicate of 82652 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.