Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87755 - rhn-applet-gui exits when any other program in system tray exits
Summary: rhn-applet-gui exits when any other program in system tray exits
Keywords:
Status: CLOSED DUPLICATE of bug 84258
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 03:06 UTC by Matthew
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:26 UTC


Attachments (Terms of Use)

Description Matthew 2003-04-02 03:06:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After any other program loads into the system tray in KDE, when that program
exits, rhn-applet-gui also quits, and must be manually restarted.

This includes programs such as: licq (with licq-kde), kmix, and ksetispy.

This has been a problem from what I have observed since the introduction of the
rhn-applet.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.9.0.1

How reproducible:
Always

Steps to Reproduce:
1. Load up KDE
2. Load up a program that puts an icon in the system tray
3. Quit program
4. Watch rhn-applet-gui disappear
    

Actual Results:  rhn-applet disappears from the system tray and process list

Expected Results:  rhn-applet should not close

Additional info:

Comment 1 Daniel Veillard 2003-04-02 08:51:26 UTC
Also reported and analyzed as #84258
Unfortunately it seems a problem on the way some X11 events are handled
and I could not debug this,

Daniel

*** This bug has been marked as a duplicate of 84258 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.