Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87748 - SMB printing config adds '\' to escape special characters in passwords
Summary: SMB printing config adds '\' to escape special characters in passwords
Keywords:
Status: CLOSED DUPLICATE of bug 80784
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-02 00:25 UTC by Phil Sharfstein
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:25 UTC


Attachments (Terms of Use)

Description Phil Sharfstein 2003-04-02 00:25:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When you enter a password in the printconf SMB Share queue type it automatically
adds a '\' to escape special characters.  This '\' goes into the
/var/spool/lpd/PRINTQ/script.cfg file, and is sent to
/usr/share/printconf/util/smbprint, which does not work, since the password has
an extra '\' in it.


For example: if you enter

pass!word

as your password in printconf, it will show up as

password="pass\!word"

in script.cfg.

Version-Release number of selected component (if applicable):
printconf-gui-0.4.24

How reproducible:
Always

Steps to Reproduce:
1.Create a SMB queue printer in printconf 
2.Enter a password with a ! character.
3.I don't know if any other chars have the same problem
    

Additional info:

Comment 1 Tim Waugh 2003-04-02 11:11:39 UTC

*** This bug has been marked as a duplicate of 80784 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:25 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.