Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87741 (rcn:timeout) - maindialog.py:198:__init__:NameError:global name 'timeout_add' is not defined
Summary: maindialog.py:198:__init__:NameError:global name 'timeout_add' is not defined
Keywords:
Status: CLOSED ERRATA
Alias: rcn:timeout
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 87991 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-01 22:32 UTC by Mark Goodman
Modified: 2007-04-18 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:10:24 UTC


Attachments (Terms of Use)
Python traceback (deleted)
2003-04-01 22:34 UTC, Mark Goodman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Mark Goodman 2003-04-01 22:32:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I click System Settings and then Network.  The attached error message shows up.

I can always reproduce it on the same installation but I can't always reproduce
it on a different installation.

The obvious 'from gtk import *' to bring timeout_add into maindialog's namespace
is not there.  This problem goes away when I add 'timeout_add=gtk.timeout_add'
to maindialog.py.


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Sometimes

Steps to Reproduce:
1.  Click the red hat.
2.  Click System Settings.
3.  Click Network.
    

Additional info:

Comment 1 Mark Goodman 2003-04-01 22:34:02 UTC
Created attachment 90817 [details]
Python traceback

Comment 2 Harald Hoyer 2003-04-02 09:18:24 UTC
or "from gtk import *" ... well, I know...

Comment 3 Cmere 2003-04-03 16:38:39 UTC
I've been able to duplicate this only when I use reiserfs as the root fs. 
Three installs with reiserfs had this issue, four installs with ext3 were 
fine. This was all done on the same machine, and with the same install discs. 
My first login to each install was with the root user, first action taken was 
to open redhat-config-network. 

Comment 4 Mark Goodman 2003-04-04 07:22:46 UTC
I can confirm that it only happened when I did a kickstart install with
reiserfs.  Installs with ext3 were fine.


Comment 5 Harald Hoyer 2003-04-04 12:45:11 UTC
try to move away either 
/usr/lib/python2.2/site-packages/rhpl/exception.py*
or
/usr/share/redhat-config-network/netconfpkg/gui/exception.py*
(but not both :)
and retry...

Comment 6 Harald Hoyer 2003-04-04 13:38:14 UTC
*** Bug 87991 has been marked as a duplicate of this bug. ***

Comment 7 Harald Hoyer 2003-04-04 13:42:21 UTC
or get new versions from
http://people.redhat.com/harald/redhat-config-network

Comment 8 Mark Goodman 2003-04-04 22:56:46 UTC
Moving away either exception.py* didn't work.

redhat-config-network-1.2.3-3 works fine.



Comment 10 Harald Hoyer 2003-05-19 11:37:37 UTC

*** This bug has been marked as a duplicate of 86060 ***

Comment 11 Harald Hoyer 2003-08-11 14:10:24 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.